Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a strange problem with Windows 7 RTM. I'm running Ultimate 64-bit edition.

Whenever I run sfc /scannow I get this error:

Windows Resource Protection could not start the repair service.

My research so far has told me that I need to set the Windows Module Installer and Windows Installer services' startup types to Manual.

They already were, so I manually started those services and tried again. No luck.

I've even booted into my Windows 7 repair disc and tried running sfc /scannow from that. All I get is this:

A repair operation is already pending.  Restart and try again.


I'm trying to run sfc because I am unable to open any images in Windows Photo Viewer. Whenever I try, I get the error "Class not registered."

I believe the problem started after I installed Gladinet, but I can't be sure. I've uninstalled Gladinet, but the problem remains.

System Restore was disabled (yes, I know I'm stupid - you don't have to remind me). Please help. Thanks.

share|improve this question
Did you take a look at the event log? It usually has much better information about things like this. You might even be able to get the actual class's CLSID which needs to be registered. But at this point it sounds like the system is far gone enough that it should be formatted and reinstalled as a matter of course. – Billy ONeal Sep 26 '10 at 3:19
up vote 0 down vote accepted

Nothing helped. I ended up having to re-install Windows 7. A friendly reminder to everyone:


At the very least, don't do it if you intend to try out beta software.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .