Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried to have win8.1 and ubuntu installed at the same time, anyway, I failed. My problem at the moment is that after that I had just Win8.1 or just Linux installed and my Laptop does not boot normally. I always Have to press F12 (Dell Latitude E6510 Laptop) to bring up my boot selection menu and select the boot method manually, so the same problem with Linux Legacy boot and Windows UEFI Boot. I tried every combination in the BIOS for the booting sequence I still get a blank screen if I don't select manually.

I hope this question is not a duplicate and that I have given you enough info.

share|improve this question

2 Answers 2

It sounds like you've installed Linux in BIOS mode to a computer that already had Windows booting in EFI mode. As you've discovered, this creates an awkward situation for dual-booting. There are numerous solutions to this problem, but the two easiest are likely to be:

  • Download the USB flash drive or CD-R version of my rEFInd boot manager, prepare a boot medium, and boot it. This should show you the rEFInd boot menu. Test that you can boot both Linux and Windows with it. If you can, then boot into Linux and install rEFInd from there. (Using the RPM or Debian package is easiest if you've got a suitable distribution; if not, use the binary .zip file.) This should fix the problem.
  • If you're using Ubuntu or a closely-related distribution, boot a Linux emergency disk in EFI mode and run the Boot Repair program. Booting in EFI mode is critical, and to do that you may need to experiment with your boot loader. Normally you'll see two entries for the boot medium, one with "EFI" or "UEFI" in the description and one without; select the entry with "EFI" or "UEFI." Verify that you're in EFI mode by looking for a directory called /sys/firmware/efi; if it's present, you've booted in EFI mode, and if not, you probably haven't. Note that Boot Repair is a cross-your-fingers-and-hope-it-did-the-right-thing sort of utility. It usually works on Ubuntu and closely-related distributions, but sometimes it does nothing useful, and on rare occasion it makes matters worse.
share|improve this answer

Just change one single setting:

  • Enter BIOS - Press F2
  • Scroll down to POST Behavior and expand the menu
  • Select the Fastboot-Section
  • Select "Thorough" or "Auto"
  • click "Apply" and Exit

This will solve the problem

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.