Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows drives are automatically mounted in Ubuntu. File operations on Windows drives had been going well until today when my operation of creating a directory on a Windows drive is denied:

$ mkdir /Windows-d/tmp  
mkdir: cannot create directory `/Windows-d/tmp': Operation not supported  

Some permission info is:

$ ls -l / | grep "Windows-d"  
drwxrwx--- 1 root plugdev 229376 2009-11-28 20:28 Windows-d  

I wonder what's wrong with it?

share|improve this question

1 Answer 1

What version of the NT filesystem module are you using. You can easily check for that by issuing

cat /var/log/messages | grep NTFS 

That should return back the version info and check with the distro's repository for a more updated version. You can check here to find out more about the driver. The other thing worth checking out is your file system table file (/etc/fstab) to see if the permissions is set for writing to it. Speaking of which, are you logged in as a normal user? Have you tried this with superuser access (root)?

As an example of such command to mount the NTFS partition here under the /mnt/Windows with readonly (-r) and umask (to control permissions), the filesystem is specified using the -t switch.

mount /dev/hda1 /mnt/Windows -t ntfs -r -o umask=0222

Here's an example of such an entry within the /etc/fstab to automatically mount the NTFS partition

/dev/hda1 /mnt/Windows ntfs ro,umask=0222 

Now, if you have this similar layout, then your ntfs partition is mounted as readonly.

share|improve this answer
    
Thanks. If I want to mount the drive with read and write, how to do it? By the way, I finally solved this problem, but not sure exactly how. My /windows-d has only about 500M left free. So I delete some files and got 1.2G free. At the same time I updated my system. After reboot, it works again. –  Tim Nov 30 '09 at 1:41
1  
@Tim: the read and write would be rw. Hmmm...It would not surprise me that because you were tight on disk space, the linux NTFS kernel module could not fully read the NTFS system folder (special folder for the NT filesystem to keep track of all files in the ntfs partition) and hence prevented the capability of writing. I would hazard a guess that is a fail safe 'feature' to prevent corruption - not 100% sure. –  t0mm13b Nov 30 '09 at 1:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.