Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Everytime I start Ubuntu I get a warning message that says my hard disk is failing. Big deal, it's just a warning, I'm a programmer, I ignore warnings (kidding).

On a more serious note: I've already backed up all my data that I need, but I gonna continue to use this computer until it explodes dag napbit! So how do I tell Ubuntu that I don't care and make it stop showing me the warning?

share|improve this question
    
+1 for "dag napbit!" –  ricbax Nov 30 '09 at 2:57
    
@ricbax: Really? If I would've know that would get me a +1 I would put that in all my post! ;-) Thanks anyway! –  Lucas McCoy Nov 30 '09 at 3:17
1  
-1 for misspelling "dagnabbit". (j/k, i wouldn't downvote for that.) –  quack quixote Nov 30 '09 at 7:58
add comment

5 Answers

up vote 6 down vote accepted
+200

I'm not completely sure if you're experiencing the same kind of message that i did, but i was told that my disk has many bad sectors, so this is how i removed the warning message:

  1. Open the Disk Utility from System > Administration > Disk Utility (or maybe a click on the warning will open it?)
  2. Choose the disk that is failing and click the More Information link. (The link is placed to the red text that is showing you the warning)
  3. Set a mark in the Don't warn me if the disk is failing-checkbox just above the attributes in the bottom of the window.

I sincerely hope this will solve all of your problems.

share|improve this answer
    
Hey that rocks - didn't know that was there! Learned something new today. Thanks, Meinertz! –  pbr Dec 4 '09 at 19:55
add comment

It would have been nice to know what was generating the warning, without any further information i search launchpad for 'hard disk failing notification', and found this

https://bugs.launchpad.net/ubuntu/+source/gnome-disk-utility/+bug/412440

which led me to this

https://bugs.launchpad.net/ubuntu/+source/gnome-disk-utility/+bug/412152

Which apparently had major work done on 2009-09-19. Makes me wonder if you're up to date. If not, update apt-get update; apt-get install devicekit-disks. If so, there should be a way with this update to disable the notification on a per device basis.

I'd suggest first following the pattern by https://bugs.launchpad.net/ubuntu/+source/gnome-disk-utility/+bug/412152/comments/32 before you jump to disable the notification.

share|improve this answer
    
good find. that should be corrected in the shipping Karmic (the bug reports it was fixed in gnome-disk-utility (2.28.0-0ubuntu1), while karmic currently installs gnome-disk-utility (2.28.0+git20091012-0ubuntu1) packages.ubuntu.com/karmic/gnome-disk-utility ) .. but if he's still running a Karmic RC he might have an older version of this utility. that is to say: check installed versions, update if necessary. –  quack quixote Nov 30 '09 at 7:57
    
I am running the stable release of 9.10. If this is a bug I wonder how many people have actually replaced their HDD's? Surely no one would just trust one tool to tell them their HDD was failing (would they)? –  Lucas McCoy Nov 30 '09 at 10:35
    
it was a bug in the RC (release candidate, a beta release) of 9.10, which hopefully was being run by experienced users who proceeded to examine their drives with other tools before replacing them. –  quack quixote Nov 30 '09 at 11:45
    
@quack: We can only hope ;-) –  Lucas McCoy Dec 1 '09 at 6:07
add comment

Perhaps disabling disk checking for the partitions on that drive would stop the errors. You can simply change the pass-num field in /etc/fstab to 0 for that disk to prevent fsck from checking the specified partitions at startup. A typical fstab looks like this:

device name   mount point     fs-type      options           dump-freq pass-num
LABEL=/         /               ext3         defaults                1 1
/dev/hda6       swap            swap         defaults                0 0
none            /dev/pts        devpts       gid=5,mode=620          0 0
none            /proc           proc         defaults                0 0
none            /dev/shm        tmpfs        defaults                0 0
/dev/cdrom      /mount/cdrom    udf,iso9660  noauto,owner,kudzu,ro   0 0

for each partition that resides on /dev/hda for example, change it's pass-num value to 0 to disable checking. You could disable checking on all of them for one reboot and see if that does anything.

share|improve this answer
add comment

Seems like an old post, but just to keep it up to date....

I had the same problem with my Ubuntu 12.04 LTS, and things seem to have changed a little.

In Ubuntu 12.04 you need to start disk utility as well, but then you should choose the drive that is experiencing errors, and then go on the link "smart Data" and you will find the box "Don't warn me if disk is failing"

Hope this is going to be helpful for a few others out there with newer versions of Ubuntu.

share|improve this answer
add comment

Disabling or overriding the udisks probe for ATA SMART support udev rule will prevent Gnome Disk Utility 3.0.2 (Ubuntu 12.04 in my case) from showing the hard disk failing notification. From the comments at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/574462/comments/7 this workaround acceptable.

Create a file with the following contents at /etc/udev/rules.d/81-udisks-no-ata-smart.rules so that it overrides /lib/udev/rules.d/80-udisks.rules.

# Force all disk probes to return not ATA SMART capable so that a drive with SMART  
# failures does not trigger Gnome Disk Utility to display a pop-up warning message. 
# Note: Some programs that rely on udisks to perform SMART checks may not work. 
#       However, manual SMART reads (e.g. using smartctl) are not be affected.

# USB ATA enclosures with a SAT layer
KERNEL=="sd*[!0-9]", ATTR{removable}=="0", ENV{ID_BUS}=="usb", ENV{DEVTYPE}=="disk", ENV{UDISKS_ATA_SMART_IS_AVAILABLE}="0"

# ATA disks driven by libata
KERNEL=="sd*[!0-9]", ATTR{removable}=="0", ENV{ID_BUS}=="ata", ENV{DEVTYPE}=="disk", ENV{UDISKS_ATA_SMART_IS_AVAILABLE}="0"

# ATA disks connected via SAS (not driven by libata)
KERNEL=="sd*[!0-9]", ATTR{removable}=="0", ENV{ID_BUS}=="scsi", ENV{DEVTYPE}=="disk", ENV{ID_VENDOR}=="ATA", ENV{UDISKS_ATA_SMART_IS_AVAILABLE}="0"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.