Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought an Acer Aspire E1-510P-4459 with Windows 8.1... And I am considering installing Linux on it; maybe Win7, but I'd need to get a USB CD for that. So I downloaded a live image of my favourite distro: Crunchbang, but I can't for the life of me, make a UEFI-bootable USB stick from it. Tried both dd (Cygwin 6) and Rufus (MBR for BIOS/UEFI since I want it to be bootable for both).

So I opted for the next best thing: since I am not intent on keeping Win8.1, I don't need UEFI at all. Rebooting into the BIOS to disable it, I find the CFM/Legacy option is hidden from me. Even the Secure boot was greyed out and could not be disabled. Fortunately, I was able to get control of the secure boot by adding a password to my BIOS. But Boot Options still had only UEFI.

I am not too familiar with Windows 8.1, but in my quest for an answer I did find tricks that other people have used to unlock their UEFI settings, but none of them gave me a legacy boot.

I have already tried using the Advanced Startup "Use EFI USB" feature, but it says it isn't finding anything bootable... And going into UEFI settings from that advanced startup does not boot me into this: http://www.eightforums.com/attachments/tutorials/16543d1360707770-uefi-firmware-settings-boot-inside-windows-8-uefi.jpg it just boots me into the F2 menu and gives me some more options to tweak the Secure Boot, but still no Legacy mode.

So, does anyone know of a trick to make it appear? It has to be there! I've seen it on other laptops; and given how new UEFI is, it needs to have backwards compatibility with BIOS.

Alternatively, how do I make my USB bootable for UEFI? Preferably manually, since I am sick and tired of all these tools. I know I have to add an EFI directory with an EFI shell, but then what?

EDIT: I guess I forgot to mention the USB key does boot on older non-UEFI laptops and has been booted on a laptop with UEFI in Legacy mode.

share|improve this question
    
You don't want to disable UEFI there isn't any need it also won't solve your actual problem. –  Ramhound Jun 12 at 20:21
    
Why not? What does UEFI offer besides incompatibilities? Protection from rootkits? Can anyone say overkill... Anyways, I've been able to boot this USB on an old non-UEFI laptop, along with another laptop that does allow legacy boot, so yeah, it is one solution to my problem. –  Enter Display Name Here Jun 12 at 22:02
    
It offers the ability to use larger disks for one. Outside of that Its the replacement for BIOS so you better get used to it. –  Ramhound Jun 13 at 10:10
    
The fact that even while still transitioning, UEFI developers have hidden, or maybe even stopped providing backwards compatibility makes it pretty obvious this is less an upgrade for an antiquated system and more of a bid by Microsoft to give users even less control of their system and make it harder to choose other OS's. To make use of larger disks, developers could have just changed BIOS from 16-bit to 32-bit... –  Enter Display Name Here Jun 13 at 15:18
    
UEFI has nothing to do with Microsoft. UEFI is what the industry decided upon. Microsoft just supports it. Secure Boot was choosen by the industry, Microsoft decided to implement support, and require their OEMs to enable it. They also require those same OEMs to provide a way to disable it in order to sell Windows on those devices. –  Ramhound Jun 13 at 15:21

2 Answers 2

up vote 0 down vote accepted

Problem solved. A 'BIOS' update from Acer did enable the Legacy boot mode choice.

Unfortunately, Ramhound, the instructions provided in the Crunchbang forum assume you can boot the installation media... And the Crunchbang developers have yet to release an EFI-bootable image. This means that I would in fact need legacy mode to install the OS and then following those instructions, make it UEFI-bootable. So you can sleep tonight, knowing I am booting my Linux through UEFI.

EFI may have started out in the 90s, but it has only recently made its way into mainstream computers/laptops. Even Hiren's bootcd hasn't yet been re-made to support it.

share|improve this answer

Right from Microsoft Technet Pages (3rd search result):

  1. Before disabling Secure Boot, consider whether it is necessary. From time to time, your manufacturer may update the list of trusted hardware, drivers, and operating systems for your PC. To check for updates, go to Windows Update, or check your manufacturer's website.
  2. Open the PC BIOS menu. You can often access this menu by pressing a key during the bootup sequence, such as F1, F2, F12, or Esc. Or, from Windows, hold the Shift key while selecting Restart. Go to Troubleshoot > Advanced Options: UEFI Firmware Settings.
  3. Find the Secure Boot setting, and if possible, set it to Disabled. This option is usually in either the Security tab, the Boot tab, or the Authentication tab.
  4. Save changes and exit. The PC reboots.
  5. Install the graphics card, hardware, or operating system that’s not compatible with Secure Boot. In some cases, you may need to change other settings in the firmware, such as enabling a Compatibility Support Module (CSM) to support legacy BIOS operating systems. To use a CSM, you may also need to reformat the hard drive using the Master Boot Record (MBR) format, and then reinstall Windows. For more info, see Windows Setup: Installing using the MBR or GPT partition style.
  6. If you’re using Windows 8.1, you may see a watermark on the desktop alerting you that Secure Boot is not configured correctly. Get this update to remove the Secure Boot desktop watermark.
share|improve this answer
    
Could the downvoter please have the courtesy of stating why it was for? The OP didn't try this solution and various systems only make it available to disable UEFI via the original OS or by an Assistance button (like SONY VAIOs). –  arielnmz Jun 12 at 21:53
    
The downvote wasn't from me, but I already disabled secure boot... Problem is the USB drive does not have an EFI directory and cannot be booted in UEFI at all. That's why I need to switch to CSM/Legacy mode, which is hidden. And as I said, the "UEFI Firmware Settings" does not boot me in the menu shown in the image. And again, I have no intent on keeping Win8, so I don't need UEFI and all the headaches it's giving me. –  Enter Display Name Here Jun 12 at 22:15
    
Well, there should be an specific method for your motherboard. And as for the EFI/UEFI thing, I think your distro has to be UEFI ready. Like Fedora and Ubuntu. You should be able to just burn the image and boot from it. –  arielnmz Jun 12 at 22:32
    
AFAIK for the USB to be bootable in UEFI there has to be an EFI directory with the appropriate EFI shell and boot config, which neither Rufus, Unetbootin, or dd create; though apparently Unetbootin can't create UEFI-bootable media, but idk what Rufus/dd's problems are... So I either need to manually create the EFI directory (which idk how), or enable Legacy boot mode - the latter should've been easier, but man was I wrong –  Enter Display Name Here Jun 13 at 1:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.