Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My chrome is set to use pepper flash (as is the default, I do not have any other flash player installed).

I am encountering a strange error where some flash files do not play. As an example the two videos on the top of this page do not play. I've seen .swf and .mp4 formats play for me and I have confirmed that two .flv videos failed loading.

How do I troubleshoot and fix this issue?

Update: I reinstalled chrome and found that on the fresh reinstall, I could play the videos but as soon as I "synched" with my GMail account and it's settings, the videos would not play anymore. Resetting the settings to default did not seem to change a thing either. The videos do play in a Linux version of the browser on the same account though which is odd to say the least.

share|improve this question
    
I tried reinstalling the browser which helped me confirm this is the result of some combination of settings. Which ones I have absolutely no idea, this is odd because I have confirmed that this is working fine within Linux but not on Windows 7. I tried changing my settings back to default but this didn't seem to help much. However before logging in to my gmail account for a sync the videos in the link above ran just fine. –  Cestarian Jun 14 at 1:33

2 Answers 2

Bypass google chrome pepperflash as long as your not on linux, to do this download the version of flash you wish current lastest is 14 from here http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html th elinks are down near teh bottom and will look like this Flash Player archives Release and Content Debugger archives

(Released 6/10/2014) Flash Player 14.0.0.125 (159 MB) (Released 6/10/2014) Flash Player 13.0.0.223 (149 MB)

extract the zip file, go into the non debug folder and look for the non ax version this will install normal flash and then in chrome://plugins click details and disable pepperflash, you will need to restart chrome aftering installing flash for ti to see it

share|improve this answer
    
I tried this (Installed flash for firefox, chrome read it, then I disabled the Pepper flash) this did not change anything however firefox does play the videos. I am pretty sure this is not a pepper flash bug as these videos also play fine on Linux. I am now using NPAPI: C:\Windows\SysWOW64\Macromed\Flash\NPSWF32_14_0_0_125.dll –  Cestarian Jun 13 at 9:07
    
Can you explain a bit more i am confused now, you said "My chrome is set to use pepper flash (as is the default, I do not have any other flash player installed)" now you are saying you have the second flash installed? is this before your question or after i suggested it? you are using linux chrome to? if you are it pepperflash is compiled slightly differently to windows so from experience i think that is why it works better on linux but not windows –  Andrew Crawford Jun 13 at 9:14
    
I did install firefox and flash for it after I posted the OP. I have dualboot and chrome on Linux too, but the issue is happening on win 7. –  Cestarian Jun 13 at 10:07
    
Ok that is fine i was just lost why you said you only had one then said two, as i said the pepperflash in linux is compiled different to windows version i have seen plenty of issues with pepperflash and generally installing full flash fixes it, i think your issue is revolving around cache, try wise 365 and ccleaner and do full clean not the standard ones you want to clean your system to be like new –  Andrew Crawford Jun 13 at 11:48
    
that did not work, and I am on a fresh install of Windows anyways (Chrome was one of the first applications I installed on it too, and this was only like 3 days ago, this has been happening from day one) –  Cestarian Jun 13 at 13:54
up vote 0 down vote accepted

I found the problem, I was running the HTTPS Everywhere Chrome (beta) extension. Turning it off solved the issue.

A workaround would be to disable the extension in incognito mode and run videos that won't play normally from an incognito mode window instead.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.