Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hi guys this problem is frustrating me.

After trying a lot of things to setup my wireless card, I decide to test it by shutting down LAN interface ifconfig eth0 down. Then, when I turn the LAN interface back on (ifconfig eth0 up), it won't let me connect again.

Anybody knows why my LAN cannot be turned back on?

Currently I "solve" the problem by restarting the whole computer, but if I ever ifconfig eth0 down again I would have to restart to bring it back :(

Edit: previously this question was a combination of 2 question, you can see the second question here.

share|improve this question
    
what do you ping? an IP address or a hostname? I suspect DNS here.. –  lorenzog Nov 30 '09 at 9:51
    
i'm pinging an IP address, and i can open that address on another computer... –  phunehehe Nov 30 '09 at 9:54
    
ok, then your problem is most likely DNS. First of all: do you have any kind of network protection (WPA, wep, etc)? Does your network card join the network correctly? (try iwconfig). If your wireless card correctly joined the network, and you can't ping a hostname - then it's a DNS problem (check /etc/resolv.conf). If you are not on the wireless network either, then you first need to join it and configure the key correctly. Do post more information please. –  lorenzog Nov 30 '09 at 10:01
    
my network is not encrypted and i have joined it (that's why i can ping IP addresses) it's true that i cannot ping hostnames, but if it's a DNS problem i should still be able to access the page using its IP address –  phunehehe Nov 30 '09 at 10:27

2 Answers 2

I suggest you read this (or the whole page, which is very well written): http://alien.slackbook.org/dokuwiki/doku.php?id=slackware:network#re_starting_a_network_interface

You can run ifconfig ... up or down to activate/deactivate an interface. But this doesn't configure the interface which is necessary to connect. As stated in the slackbook page you linked to, the rc scripts need to be run. This is to set the IP addresses according to the configuration files (e.g. dynamic or static address configuration), connect to wireless networks (in case it is a wireless interface), etc.

share|improve this answer
    
thanks for the link, but I have already run those scripts so many time now –  phunehehe Dec 1 '09 at 8:57
up vote 1 down vote accepted

Well, this would solve the problem:

/etc/rc.d/inet1 eth0_restart

But personally I think ifconfig eth0 up should be enough, maybe slackware is being weird...

share|improve this answer
1  
Simply setting the interface to up does not set its IP address and netmask, nor does it start the DHCP client software. –  Kevin Panko Dec 17 '09 at 17:31
    
yeah you are right, maybe I have been spoiled by ubuntu, which does that automatically when I ifconfig eth0 up –  phunehehe Dec 18 '09 at 15:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.