Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

First of all, let me explain the layout. I've been using a CoreAVC for dual core playback. It's not that bad and if I bought it, I should use it, but I don't really like it. Why? I've got an ATI and an Intel VGA in the laptop. Because of this (no Nvidia GPU), the CPU is almost on fire when I try to play a fullHD video.

I found a way to play HD movies easily. It's the DXVA acceleration. I'm using CCCP codec pack. Used to disable the h.264 internal ffmpeg codec. By this, MPC-HC was using the CoreAVC stuff. Now, I found out, that I can use a new snapshot of ffdshow, which comes with DXVA. So I set the internal encoding to h.264. Downloaded ffdshow The good thing? DXVA works. Flawless, low CPU. Problem? No subtitles. I can see the subtitles at the tray ffdshow icon, select them, but nothing happens.

And yeah, that's quite annoying since I only watch movies in native languages, and I like to watch Anime, and if anyone watches it too.. then they know that it's a bit hard to understand without subtitles.

PS: DirectX is updated, and the driver is the latest what comes from Lenovo. IIRC 9.9 Catalyst and the latest Intel driver.

share|improve this question
    
I forgot the mention. The installed version: rev:3124, 2009-11-03 –  Shiki Nov 30 '09 at 15:14
add comment

4 Answers

I know this is an old post, but I figured I'd update it :).

The Combined Community Codec Pack comes with at least three renderers for H.264/VC1. I got the following CPU Usage for each on an AMD Phenom II 720 @ 800 Mhz (stepped down due to reduced CPU usage). 1280x720 Anime source:

FFDShow libavcodec:  around 60%
FFDShow DXVA:     around 40-50%
MPC DVXA:         around 20-30%

To use subtitles for MPC DVXA you need to do the steps posted above so that it uses the proper filter to create the subtitle overlay.

To use subtitles for FFDshow libavcodec you can either use an external renderer such as VOB Filter, you can enable it in FFDshow Video Decoder Configuration, or you can use MPC-HC's internal subtitle filter.

For FFDShow DXVA subtitles you need to enable them inside FFDShow DXVA Video Decoder Configuration. A good guide for this is at:

http://www.thehtpc.net/htpc/ffdshow-dxva-with-subtitles-i-think-so/

share|improve this answer
    
Thanks for the update! –  Shiki Jul 19 '11 at 7:51
add comment
up vote 1 down vote accepted

Found the solution: CCCP codec pack with Media Player Classic HC and DXVA (with subtitles)

First of all, you have to grab some stuff from the internet. You'll need these: 1. CCCP pack 2. FFdshow 3. Haali (All from their original websites. Use the "free-codecs" FFdshow.)

Install CCCP without installing ffdshow and haali. Unselect them at the install screen. Now, install ffdshow (You may want to enable subtitle support and disable deblocking (its at the bottom, under "Tweaks")), haali. Use the basic settings, you shouldn't adjust anything unless you know what you are doing.

Now, start Media Player Classic HC. Go to Options (View->Options). (Here, I usually select the "Remember last window size, position" and uncheck the "Auto-zoom" at the "Playback" part, but that's only because I love Smplayer's behaviour).

This one will depend on the OS. If you use XP, select VMR9 (renderless). If you've got Vista+, use EVR Custom Pres. ** (Reduce EVR buffers to the lowest possible value).

At Internal Filters (right), select: H264/AVC (DXVA), H264/AVC (FFmpeg), VC1 (DXVA), VC1 (FFmpeg).

Go to External Filters. Click on "Add Filter..." and select ffdshow Video Decoder. At right, select "Block".

Finally, go to "Playback" (left 'tree view') and select "Auto-load subtitles". Click OK, restart MPC-HC and see if it works.

share|improve this answer
add comment

I don't see the point : install ffdshow and blocking it in mpc-hc. btw, I thought ffdshow was useless for dxva.

share|improve this answer
    
Well.. the point is, that you block it in mpc-hc. The inner filter. But that's as far as I know. If you try this method, it works flawless. One bug I know: If I switch VGA (from Intel to ATI or vica versa) AND if I suspend, it wont continue playing. Have to reopen the file. But thats all. –  Shiki Jan 12 '10 at 14:46
add comment

instal kaza-lite mega codek pack, and swich on subtitle in the ffdshow. if u use all player and have problem reneme sub or what else as srt file

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.