Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this problem on two of my new laptops and can't seem to find a decent workable solution elsewhere in forum land. The problem is that on my Windows 7 Professional machines the right mouse button doesn't show the New Folder option and elsewhere as well (via Explorer) I'm unable to create new folders.

I'll be happy to get this tiny problem resolved and declare that Windows 7 is almost perfect! Thanks to all of you in advance for your contribution!

PS: None of the Vista solutions seem to work here!

New folder blues...


Tried NewFolderFix.reg, didn't work - "Not all data was succesfully written to the registry. Some keys are open by the system or other processes."

Converted FolderFix.reg to .inf file and that worked.

Don't recall the problem appearing after an update.

MS answer to the explore process hanging (KB 972685) was to install the latest Visual C++ Update (vcredist.exe).

Nope. That didn't help either.

I haven't touched Silverlight since installation when Windows 7 hit the shelves. I tortured the RC installation before that, and never had problems there either.


UPDATE-

Logged back into Administrator account, still missing from there. Spent a bit more time looking instead of just fixing. Just yto make sure, logged back into my user account - still OK there.

Turns out the entries in HKCR\CLSID were the culprit here. Reg file wouldn't take again (as above) but inf file fixed it. This key was unable to be entered from regfile, or altered or deleted in Regedit (Permissions).

Don't quite understand why a common key in HKCR needed to be entered separately for each user.

Here is the file I used to fix it. Just copy into notepad, save as newfolderfix.inf, rt-click and select Install

================================================================

[Version]

Signature=$Windows NT$

[DefaultInstall]

AddReg     =REGEntries.AddReg

[REGEntries.AddReg]

HKCR,"%String0%",,0x0,"CLSID_ExecuteFolder"

HKCR,"%String0%\InProcServer32",,0x0,"ExplorerFrame.dll"

HKCR,"%String0%\InProcServer32","ThreadingModel",0x0,"Apartment"


[Strings]

String0 = "CLSID\{11dbb47c-a525-400b-9e80-a54615a090c0}"

=============================================================

Thanks to others who helped point me in the right direction.

share|improve this question
2  
What user account are you using? Does it have admin rights? –  trip0d199 Nov 30 '09 at 14:24
1  
Can you create a new folder in an application or by a script? –  Guy Thomas Nov 30 '09 at 15:20
    
@trip0d199 I'm using the main account that was created when I first installed the OS. I think it has admin rights since I'm able to setup Security on folders, etc. @GuyThomas Yes, I can do so via say Dreamweaver and it would create a new folder easily. I haven't tried using a script. –  ymasood Dec 1 '09 at 14:23
    
So finally Reinstall 7 ! –  ukanth Dec 11 '09 at 12:34
    
not sure what the solution is.. BUT if you really need to create a directory you can always do it the old fashioned way. shell to DOS and type "MD" ! –  NoCarrier Feb 16 '10 at 21:00

9 Answers 9

Firstly, I had the same problem as you with Windows 7 Ultimate and to solve this problem, I just double clicked the following registry script.

So people - simply click the following link and run this Create New Folder fix OK!

Link: http://www.vistax64.com/attachments/tutorials/7715d1225832927-new-folder-newfolderfix.reg

Don't worry, it works in both Windows Vista and Windows 7 and will fix this issue instantly. I would also suggest, that you store the file on the hard drive and link to it for a few days, just in case the create New Folder option does a disappearing act on you again.

share|improve this answer
    
Please be sure to download the file and save it on the root area of your main systems hard drive and then link to it via a desktop shortcut because, if it goes missing again and it sometimes does, you can quickly click the link and restore the Create New Folder Option - Enjoy! –  user29023 Feb 22 '10 at 13:03
2  
I got an error ("could not import everything...") but it still fixed the problem for me. Thanks a lot! –  mafutrct Mar 7 '10 at 12:07
    
It did not fix the problem for me right off, but perhaps the following will help someone else in the future: when the registry editor window shows up (that is, you are no longer dependent on explorer.exe), close explorer.exe via the Task Manager (this shuts down your desktop,too, which is necessary), run the edit, and restart explorer.exe. Should be fine then. –  Sean Allred Sep 3 '13 at 23:17

See Microsoft's New command missing in Windows Explorer:

After you install Internet Explorer with the Windows Desktop Update component, the following symptoms may occur:

  • When you click the File menu in Windows Explorer, the New command may be missing.
  • When you right-click the desktop, the New command may be missing from the context menu.

To resolve this issue, use Registry Editor to verify that the registry key listed below has the value listed, and if needed, edit the value to match the value listed.

Registry key:
HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\New\ (Default)
Value for (Default):
{D969A300-E7FF-11d0-A93B-00A0C90F2719}

NOTE: This registry entry only exists if the Windows Desktop Update component is installed. If the Windows Desktop Update component is not installed, add the registry entry and (Default) value.

share|improve this answer
    
This registry key already exits and the value is the same as the one listed above. So still looking for a solution. –  ymasood Dec 8 '09 at 12:14
    
I find that hard to believe. Have you checked the permissions on this key? –  harrymc Dec 11 '09 at 9:41
    
Yes, checked the permissions, still nothing, Users and Admin have Full Control! –  ymasood Dec 13 '09 at 13:02
    
Big mystery. What happens when you boot in Safe mode? –  harrymc Dec 13 '09 at 15:34

You can fix this problem from the Windows Registry.

From the start menu, run regedit.

Browse to the key: HKEY_CLASSES_ROOT\Folder\ShellNew

If the key doesn't exist you can create it. You can check this key out, be sure that everything matches up with the images below.

(( spam prevention keeps me from posting helpful images, see comment below ))

You may have to create the \Config key as well, depending on how messed up everything is. But once you match everything to the pictures it should work fine.

Edit:

Check your HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder it should be identical to the above mentioned registry key.

It could also be a permissions issue. From command prompt try

icacls C:\Users\USERNAME\Desktop /grant USERNAME:f /t

Last but not least super registry key fix. Adds all of the folder keys (except for HKEY_LOCAL_MACHINE). included are: HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\New HKEY_CLASSES_ROOT\CLSID\

share|improve this answer
    
image 1: i50.tinypic.com/1zfsx1g.jpg –  grooveDexter Dec 12 '09 at 2:23
    
image 2: i47.tinypic.com/t7n2v7.jpg –  grooveDexter Dec 12 '09 at 2:25
    
grooveDexter, both of those are an exact match in my registry. They exist... ! –  ymasood Dec 12 '09 at 18:40
    
few other things to try, see the edit to above post –  grooveDexter Dec 16 '09 at 12:45

I had the same problem. I suspect it comes from the installation of a utility that modifies this shell menu, but deletes wrong things at the same time.

Based on the information I saw above, I had to recreate three registry entries for it to work. One seems to refer to the shell in general; a second to the Folder context menu; a third one to the desktop context menu. It may be that other entries are missing, if there are other context menus where a new folder can be created, but at least this worked for me.

Thanks for all others for giving me the basis elements for this. This is the RegEdit (.reg) file; you can create it with notepad; save it and execute it.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers\New]
@="{D969A300-E7FF-11d0-A93B-00A0C90F2719}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\ShellEx\ContextMenuHandlers\New]
@="{D969A300-E7FF-11d0-A93B-00A0C90F2719}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\DesktopBackground\ShellEx\ContextMenuHandlers\New]
@="{D969A300-E7FF-11d0-A93B-00A0C90F2719}"
share|improve this answer

Try launching this reg file.

share|improve this answer
    
Tried that on 11/11/09 and it doesn't work. –  ymasood Dec 5 '09 at 16:07

New feature in Windows 7 is Ctrl + Shift + N to make a new folder.

It doesn't explain your problem, but it might function as a workaround and help diagnose the problem.

share|improve this answer
1  
I tried this earlier and it won't work. Also, the idea of the question is to find a solution that can be helpful to other users as well. :) –  ymasood Dec 1 '09 at 14:24

You can use a script, open the Command Prompt and

cd "C:\Users\Me\Desktop"

to the directory. Then, type in the following.

mkdir "Directory Name"

If even that does not work; contact your provider. You'll get a new Windows 7 disc I guess.

share|improve this answer
1  
This is not practical and that's not how the OS is supposed to be used in such cases a solution is being asked for and not a work around. Second supplier of my disk is Microsoft via MAPS and one of our other laptops just works fine without this issue. –  ymasood Dec 5 '09 at 16:08
    
Then, i can't help you anymore. This is all the help i can get for you. –  Deniz Zoeteman Dec 5 '09 at 20:57
1  
But does that workaround even work? I know you want a solution, but there's also the current need to actually have a new folder. –  Daniel H Dec 9 '09 at 22:08
    
Daniel, TutorialPoint, yes using mkdir works, creates a new folder quite easily. –  ymasood Dec 12 '09 at 18:46

Try the registry script "NewFolderFix.reg" and restart your computer afterwards.

It should fix your problem.

And, did you check Updates? Maybe there are no important updates, but maybe some additional updates on drivers. Even the craziest, where you wouldn't expect it to cause problems, can sometimes cause problems. Windows 7 is a new OS, and debugging is not a great point at Microsoft. Just saying.

Otherwise, try a system restore point from where there was no problem.

share|improve this answer

Try using FreeCommander or TotalCommander (as an administrator!) and try creating a folder there. If that doesn't work, then your administrator rights are somehow broken!

share|improve this answer
    
Could this be accepted as a workaround? I mean, additional programs is kind of irritating, and does not give you a decent workaround, i guess. –  Deniz Zoeteman Dec 10 '09 at 19:37
    
I can't help him with hiw "new > new folder" because I never use it this way. I don't use the windows explorer ever, not once since Win 95. I switched to TotalCommander as file manager. If even TotalCommander can't create folders, in administration mode, then clearly his admin rights are broken somehow. –  Don Salva Dec 10 '09 at 21:16
    
NoCanDo, valid point, need to address the real problem though. So far none of the proposed solutions have rectified the issue, so there is something really not quite right. How do I go about checking whether my admin rights are broken or not? I am able to create new folders via the command prompt. Thanks! –  ymasood Dec 12 '09 at 18:49

protected by studiohack Mar 16 '11 at 19:29

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.