Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought a brand new 8gb pen-drive today with the purpose of putting on a .iso file for a new Linux distribution.

I used

sudo dd if=/path/to/.iso of=/dev/sdb 

to write the .iso to the usb drive.

After restarting, and changing the boot order of my drives, boot up went straight to the grub menu.

After reattempting this several times, I conclude that the that there was some problem with the .iso file, or something. I want to erase all of the data on the usb.

So, in trying to reformat the usb, to write over the data I did the command 'df' and my usb drive did not show up mounted. I tried using gparted to delete everything and then format to fat32, and gparted gave me an error.

Is there any suggestions as to how to delete everything on the usb drive, or how to reformat it so as to put a new .iso file on there?

This is on a machine running openSUSE.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

This will wipe entire contents of sdb (the usb in your case).

sudo cat /dev/zero > /dev/sdb
share|improve this answer
    
ok im doing that now; meaning, i copied your command into my terminal about 20 minutes ago and it still has not finished. does 'cat' generally take that long? –  user74091 Jun 16 at 0:11
    
'cat' just outputs the contents of the file. When used like this it will just keep going until all of sdb is set to 0s. By now, the entire partition table (at the beginning of the drive) is wiped, so you could stop it and gparted should work. –  apple16 Jun 16 at 0:25
    
ok awesome, that worked –  user74091 Jun 16 at 0:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.