Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Group Policy set from windows 2008R2 domain controllers. The clients are all Windows 7 (Ultimate) machines. I have a group policy set that locks the clients after 5 minutes of inactivity. Each work station has one user signed in, all users have roaming profiles.

When starting from the lock screen, users enter Ctl + Alt + Del and go to the authentication screen. For one user, instead of the authentication screen...the switch user screen appears, with only one profile to select.

This user is the only user logged in. When logging into her account on a different station, Windows goes from the lock screen to the authentication screen. This makes me think that it's a registry setting, somewhere in HKLM or HKCU, however I haven't been able to find any information about the lock screen or change user registry settings.

Lock Screen:

Lock Screen

Select User Screen (the screen I want to bypass):

Select User

Authentication Screen (I want to go directly here):

Authentication

share|improve this question
    
Can you try a new user profile on this computer? –  harrymc Jul 3 at 17:47
    
I just went to test it again, and it seems to have sorted itself out. If it the problem happens again I'll test a different user. –  Ben Plont Jul 3 at 17:57
    
If I understand this correctly, then this should work. Do I understand the question correctly? –  ṧнʊß Jul 3 at 18:23
    
It's close, but not what I'm looking for. The computer in question is on a domain. The first answer is for fast switching between one active account to one of several other local user accounts on the same computer. We have roaming profiles, and rarely have two accounts logged into one computer. –  Ben Plont Jul 3 at 18:43
1  
@harrymc I thought about that but reconsidered. Just because the situation resolved doesn't mean the question doesn't remain. Someone may know why the situation occurred, and the steps to take to fix it. I had an after thought that maybe it was a roaming profile that didn't load correctly some some group policy settings didn't get applied. I want to give the question a chance to get answered (bounty expires) before I take it down. –  Ben Plont Jul 4 at 20:54

1 Answer 1

How about disabling the fast-user-switching in registry?

try with the following :

1)Start -> run --> regedit

2)Navigate to

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

3)In right-side pane, create a new DWORD value HideFastUserSwitching and set its value to 1

Now with this setting Switch User option will be disabled from Welcome screen as well as from Shutdown menu.

this will help you to bypass the user selection screen.

hope it helps

share|improve this answer
    
I thought about that tweak...my concern is that I wouldn't be able to log in with admin accounts that have login scripts that access network drives - that regular users can't access. –  Ben Plont Jul 9 at 18:48
1  
@BenPlont You would. You'd just have to kick off the currently logged-in user. –  Iszi Aug 20 at 16:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.