Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have had a problem both on my machine and on countless machines I manage. Basically, Search in Outlook 2013 is shockingly bad and just doesn't work.

Personally, my standard email setup consists of 2 Exchange accounts and 1 SMTP/IMAP account. On Outlook 2010, I had no issues. I had a family member complain about this issue, and at that point, I thought it was just them... I then upgraded my work machine - and had the same issue. Thinking this was a one off, I upgraded my home machine and had the same issue and finally, when I came to rebuilding my laptop, I couldn't find my 2010 install and just used 2013, and, it happened again!

I have talked to friends who manage the infrastructure in 1000+ person companies who also confirmed issues. One person told me that they worked with Microsoft Professional Services who gave them a registry fix and patch which they applied and they reapply after updates or every so often when the issue resurfaces. Due to contractual arrangements, I haven't been able to see this patch nor do I know how it works or what it does.

I have done the usual - unchecked the reduce search results to improve search performance, along with rebuilding the cache several times but I haven't got anywhere.

the only "solution" I have found is to login to OWA, where everything actually works.

For example, searching for the same search term on OWA and on Outlook 2010 show identical results, where as Outlook 2013 simply misses all results from the last few weeks:

enter image description here

Does anyone know what is going on?

William

share|improve this question
    
It's a BAS (Bad Ass Software) or a BUG (Bad Ugly Gimmick). I remember having problems with the index in Outlook 2007 and 2010, and in 2007 more so than in 2010. These problems were all related to index corruption. In Outlook 2010 I hardly had any such problem. I have upgraded to Outlook 2013, but I have not seen this type of problem yet. I'll let you know if I do. I have thousands of e-mail in Outlook, just asking for trouble, so it shouldn't take long before it starts throwing errors and such at me. :) –  sammyg Jun 17 at 14:14
    
Sorry I can't be of any more help. The best thing I can do is recommend that you downgrade to Outlook 2010, if you still have it. Wait until they have sorted this out, till they release a few major updates. (The usual precaution with M$ crapware). The entire Office 2013 suite was a big disappointment for me. Just looking at the pale, plain flat GUI makes me sick. It's buggy too. So stay completely away from it if you have the luxury. –  sammyg Jun 17 at 14:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.