Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a .p12 certificate that was issued to me by my university. I have been able to install it on OSX just fine, but I need to use it for Cisco Anyconnect in Linux Mint 17. When I double click it, I get prompted to enter my pin, where I can then view information about it, but the import button on the bottom right of the window is deactivated, so it seems it won't accept that certificate. I then tried openssl pkcs12 -in cert.p12 -out cert.PEM. When I tried it with that, the import button was still deactivated. I already asked this question on the Linux Mint forums about 5 days ago and have had no replies. How can I install my personal signing certificate on my machine? Thanks.

share|improve this question

1 Answer 1

I had the same problem. I needed the certificate for an Internet application. I was first unsuccessfully trying to import the certificate like you were, but it turned out that all I needed to do was to import certificate to my browser.

EDIT: I just copied the .p12 file somewhere in my Home folder. Then I imported it to Google Chrome, which is my default browser. You can follow these rules on importing certificate:

https://antportal.com/wiki/installing_client_certificates/

share|improve this answer
    
Welcome to SuperUser, thanks for your answer. Could you edit your answer to add some detail on how you achieved this please? It will help everybody understand exactly how to fix the problem. –  Andi Mohr Oct 10 '14 at 10:06
    
Try here superuser.com/questions/770717/… it suggests that Cisco AnyConnect will use browser imported certificates. In most browsers you can import from security options. –  Enis P. Aginić Oct 10 '14 at 11:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.