Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using Pentadactyl, when I press the Alt key, it toggles the menu bar, and the --MENU-- mode. This is very embarrassing for me, as I use dwm window manager at the same time, where Alt is the most important meta key, so I hit it very often. How can I disable Pentadactyl's behaviour? I mean, I want it to do nothing when I press Alt. I already tried to remap Alt or Meta to nothing:

:map <A> <Nop>
:map <M> <Nop>

But it doesn't work.

share|improve this question
    
It’s very strange for me since on my system <Alt> does not set focus on menu bar neither in Pentadactyl nor in pure Iceweasel (Firefox) nor in any GTK+ app. And I don’t remember that I’ve done anything special to disable it. So most probably your question have no any relations to Pentadactyl. –  Dmitry Alexandrov Jun 18 at 12:30
    
Thank you for your comment! You are right, this keystroke is just passed to Firefox, and it only does it's default behaviour. I found the solution, I will write it in an answer. –  deeenes Jun 19 at 23:44

1 Answer 1

up vote 6 down vote accepted

Actually recently this is the normal behaviour of Firefox. Recently, because few versions earlier it was not like this. And using extensions like Pentadactyl or Vimperator, it is very apparent and annoying, while possibly with the default user interface it's convenient. So I searched for related Firefox settings, and I found, the ui.key.menuAccessKey and ui.key.menuAccessKeyFocuses. First I had the intuition that the first needed to change, which was set to 18, which means the Alt key. I set it to 0, without any effect. Then I changed the latter, from true to false, and the issue become resolved.

share|improve this answer
3  
Right now, you need to change ui.key.menuAccessKey. ui.key.menuAccessKeyFocuses will be reset (on start?) if you have the menu bar hidden, so it most likely has no (useful and persistent) effect. This is part of a "bug fix", also introduced to solve what is an accessibility problem for people who use the menu bar interface. Apparently, under GTK, this setting is explicitly set to the boolean negation of the visibility attribute of the menu bar. –  njsg Jun 28 at 7:59
    
Thanks for pointing this out, indeed, the ui.key.menuAccessKeyFocuses is reset at restart, and sometimes randomly while running. Now I changed ui.key.menuAccessKey to 0, and surprisingly it works. –  deeenes Jul 1 at 10:44
    
@njsg I found out that ui.key.menuAccessKeyFocuses is set to true when you hide menubar with set guioptions-=m. So you have to place set! ui.key.menuAccessKeyFocuses=false after set guioptions-=m in your ~/.pentadactylrc. –  Dmitry Alexandrov Jul 24 at 16:45
    
@njsg What I said in previous comment is enough for FF 30, but not for FF 31 where you indeed need to set ui.key.menuAccessKey=0 –  Dmitry Alexandrov Jul 26 at 15:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.