Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed Windows 8.1 Pro on my MacBook using Bootcamp. Before doing this, the startup sound that gets played whenever you turn on the MacBook would play through my earbuds if they were connected. However, after installing Windows 8.1 alongside OS X using Bootcamp, it always plays the sound through the laptop speakers.

I don't understand why this is happening.

It's a fairly trivial issue, sure. But if I'm in the library turning on my MacBook and happened to have left it at a high volume, I'd rather not have it make a loud, obnoxious noise.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

The startup chime always plays through the internal speakers, even on desktop models. This is a feature of the firmware and can't be helped. But you can mitigate it.

Macs remember the different volume levels for the internal speakers vs. the headphone jack, and it saves this information to the PRAM. So all you have to do is unplug your headphones (that's the important part), then mute the volume and reboot. You will notice that the startup chime no longer happens.

Once you've rebooted, you can plug your headphones back in. Any volume adjustments you make while the headphones are plugged in will not affect the volume of the internal speakers.

share|improve this answer
    
Note, you have to do this in OS X. The OS X audio driver sets the PRAM value, but I don't think the Windows driver does. –  Wes Sayeed Jun 18 at 20:37
    
Ah interesting. I think I may have been mistaken then, when I said that prior to the installation it would play through the earbuds. I've used the strategy where I mute the sound before shutting down many times. Quite honestly, I don't think I've rebooted many times while the earbuds were plugged in. And if so, I probably instinctively muted the sound. I suppose that's why hearing the sound after installing windows confused me, since I had my earbuds plugged in. But yes, it makes sense now that the sounds just always plays through the speakers, like you said. –  Wolfram Jun 19 at 0:42

You can disable the hardware startup chime by changing the firmware variable SystemAudioVolume.

To disable the chime execute from the command line sudo nvram SystemAudioVolume="%80".
To return the chime to its default state execute sudo nvram -d SystemAudioVolume.
More information about the nvram command can be found in its manual pages (man nvram).

share|improve this answer
    
Good tip. I remember that command from a long time ago but had completely forgotten about it until you mentioned it. –  Wes Sayeed Jun 25 at 6:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.