Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Running filezilla 3.3.0.1 (and slightly older versions exhibit this behavior as well) to Red Hat Enterprise 5x with filezilla server, we are getting doubling of text files on overwrite. It seems to affect php, js, html files but maybe not binary files although that's not thoroughly tested. We've looked at the settings on the client and found one we thought was the problem which was 'allow resume of ascii files' which states in the client that if ticked can cause problems with line endings differing from platforms, but we've unticked this option.

so here's what happens:

We open the client, connect to ftp server. Upload a local file and choose 'overwrite' of remote copy. Filesize should change slightly (should slightly increase, ex: 117kB -> 118kB), instead it does not refresh the filesize. You hit the manual refresh button and suddenly the remote copy's filesize is reported to be doubled or more (ex: 275kB). What the heck is going on??

When we redownloaded some of these files it was as if a concatenation was happening (appending random extra contents). Obviously this will not fly to micromanage files- our whole system could be screwed up completely by this. Please help!! Is this a permissions/ownership issue or something really weird happening with either the filezilla client or server?

share|improve this question

migrated from stackoverflow.com Nov 30 '09 at 19:53

This question came from our site for professional and enthusiast programmers.

add comment

3 Answers

A slight difference in size is normal, but not doubling in size.

Try this: create a text file with a paragraph or so. Upload it. Then close down the filezilla client and open it up again and upload it. Check the filesize. If it is doubled, then open up the file on the linux server (in vi, emacs, whatever) and see if it is indeed appending the file. If it is:

  1. Try adjusting settings in the FTP client (transfer type, etc)
  2. Try another FTP client to see if it's a client issue. Try WS-FTP or FireFTP.
  3. Try FTP from the command prompt
  4. Try uploading from another machine.

If it still has the problem after this, you know it's not your client. At that point, I would:

  1. Restart the FTP server
  2. Double check all FTP settings
  3. Double check permissions
  4. Install another FTP server program

And at some point, you should eliminate the problem. It's either your client or server, so narrowing it down to which one it is should help.

Good luck with your project, and I hope this helps.

share|improve this answer
add comment

Do you have access to the Red Hat server? If so, what does the filesize show on that machine? If I had to guess it is probably a Filezilla bug, as a quick search turned up a bug report similar to what you experiencing here: http://trac.filezilla-project.org/ticket/4788.

share|improve this answer
add comment

After talking to rackspace, it turns out it is related to a sticky bit and setguid issue they had set for us on the webroot folder that was allowing us to write to the file but not destroy it first so the net result was a concatenation/append of new contents to the end of old contents. We were trying to have the web server user be the owner and the web server group be the same group as the ftp-ers group so that there was an ownership and full access for apache and yet read-write permission for ftp users and read-only perms for world-readable documents to be served as outlined here: http://www.washington.edu/itconnect/web/publishing/permissions.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.