Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently changed my monitor to LG Flatron W1941S. (When I say changed, I mean I just unplugged the older one and plugged in the new one.)

For some reason, I am stuck with maximum screen resolution 1360*768.

On another PC the same monitor easily provides resolutions till 1400*900

Here is my /etc/X11/xorg.conf file (I changed it after a reading tutorial somewhere):

# Xorg configuration created by system-config-display

Section "ServerLayout"
    Identifier     "single head configuration"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option	    "XkbModel" "pc105"
    Option	    "XkbLayout" "us"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    ModelName    "LCD Panel 1440x900"
    Modeline     "1440x900_75.00"  136.49  1440 1536 1688 1936  900 901 904 940  -HSync +Vsync
    HorizSync    31.5 - 74.7
    VertRefresh  56.0 - 65.0
    Option	    "dpms"
EndSection

Section "Device"
    Identifier  "Videocard0"
    Driver      "intel"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Videocard0"
    Monitor    "Monitor0"
    DefaultDepth     24
    SubSection "Display"
    	Viewport   0 0
    	Depth     24
    	Modes     "1440x900" "1280x1024" "1024x768"
    EndSubSection
EndSection

Do I need to install any drivers? What am I missing here?

share|improve this question

2 Answers 2

Upgrading would almost definitely fix the issue. The computer is still going off the old monitor's drivers. There should be an option in the system setup to change the monitor driver. If not, you may have to change the xorg.conf. Maybe try running system-config-display as root, as the first line of your xorg.conf says.

Also, you say that the monitor is 1400x900 which could cause an issue with the xorg.conf saying 1440x900. I don't know if that's the issue, of course.

share|improve this answer

You can begin by upgrading to Fedora 11.

Also, newer versions of Xorg are very good at autodetection. Comment out Modeline, HorizSync, VertRefresh options. Restart X to see if it works.

You can backup the xorg.conf, and remove it altogether. That way, it works much better sometimes :)

Warning If you can't use console to bring back a non-working X, don't try these at home, try it along with a linux guru(or another computer connected to IRC/superuser) :D

share|improve this answer
    
I didn't have these lines in the first place, so added them to see if it helps.. Any other tips? I think I am going to upgrade to Fedora 11 (9 is pre-independence now!) –  Swanand Jul 15 '09 at 16:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.