Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought an HTPC based on the GA-E350N WIN 8 and using a TL-WN723N for WiFi.

From day 1 I started to have problems with the computer losing WiFi connection and the yellow exclamation mark appearing or the TL USB adapter disappearing from the network adapters. To fix the problem I have to unplug and plug the adapter again. This happened both in Windows 7 x64 and Windows 8.1 x64.

It's definitely a problem with the computer since I've tried the wifi adapter in other computers and it worked just fine.

I already unchecked the "Allow the computer to turn off this device" and also disable USB selective suspend.

What could it be?

share|improve this question

closed as too broad by harrymc, Jens Erat, Breakthrough, Kevin Panko, Moses Jul 3 '14 at 17:17

There are either too many possible answers, or good answers would be too long for this format. Please add details to narrow the answer set or to isolate an issue that can be answered in a few paragraphs.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Have you installed the TL-WN723N driver ? –  harrymc Jun 24 '14 at 10:42
    
@harrymc Yes, of course. –  emzero Jun 24 '14 at 12:11
    
"day 1" - is this a new computer? If so, use the warranty. –  harrymc Jun 24 '14 at 16:16
    
Yes, I'm going to use it but I can't think of a hardware fault causing this kind of behaviour. –  emzero Jun 24 '14 at 20:21
    
What is the error message when you hover over / click the yellow exclamation mark? That will tell us more about the problem(s) you are experiencing. –  Roald van Doorn Jun 30 '14 at 14:12

1 Answer 1

Sounds like this could be due to your laptops power saving mode settings.

  • Head to Control Panel
  • Power Options
  • Click on "Change Plan Settings" (On the power save mode you're using)
  • Click on "Change Advanced Power Settings"
  • Wireless Adapter Settings
  • Select both 'Battery' and 'Plugged In' to "Maximum Performance"
share|improve this answer
    
Didn't realise that you're not using a Laptop! Sorry! Although try this anyway. You may still have the power save mode for wireless enabled. –  Joey Jun 30 '14 at 13:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.