Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a laptop (pre-installed Win8) that has been through numerous dual-boot configurations. At one point, I had removed everything and ran Linux Mint as the only OS. Eventually, I decided to remove that and reinstall Windows 8.

Upon doing so, I had a number of drivers to install/update in order to restore some basic functionality (USB ports, HDMI, FN keys, etc.). This was relatively easy to fix as all the drivers I needed were online. The problem I'm left with though, that I haven't found anything which pertains to my specific situation, is that I can no longer boot into UEFI mode.

When I was running Linux Mint as my sole OS, I left UEFI boot mode enabled with Secure and Fast boot both off. In order to reinstall Windows 8, I burned the ISO to a USB and the ONLY way it would work is if I turned UEFI mode off, and used CSM Mode.

Since reinstalling Win8, I cannot boot into UEFI mode. Which is ultimately, I think, affecting my wishes to dual-boot Ubuntu alongside Windows again.

Any ideas as to how to fix this?

@Lưu Vĩnh Phúc , does this help?

enter image description here

share|improve this question
    
is your HDD converted to MBR when installing Linux Mint? I've seen some stupid UEFI "automatically" decides to boot in BIOS or UEFI mode depending on HDD formats –  Lưu Vĩnh Phúc Jun 22 at 2:20
    
You mean in the past? I'm not sure how to check this... –  Joe Jun 22 at 2:22
    
open gdisk/gparted/whatever disk editor and make sure that the HDD format is GPT –  Lưu Vĩnh Phúc Jun 22 at 2:24
    
Just to be sure, you mean the Windows partition? I've set aside some space for Ubuntu –  Joe Jun 22 at 2:27
    
no, that the harddisk format –  Lưu Vĩnh Phúc Jun 22 at 2:33

2 Answers 2

up vote 1 down vote accepted

Windows (and many other operating systems) requires GPT to be able to boot on UEFI systems. And some UEFI systems automatically boot on legacy BIOS mode if it detects the HDD as "legacy" MBR.

So you must convert the disk to GPT. But gparted is very slow on disk operations, and it can't convert MBR to GPT too (that's a long time ago, I don't know if newer versions can, but I doubt that it can). As a result if you don't want to lose data you must use another partitioning tools like AOMEI Partition Assistant or Partition Wizard to convert

share|improve this answer
    
as it said, your GPT is error and you need to fix. If it has windows 8 pre-installed then definitely it was GPT at first. But I don't know what you have done to that drive so if you can make sure that it still has a correct GPT structure, select Yes for it to fix, otherwise you need some other ways –  Lưu Vĩnh Phúc Jun 22 at 4:03
    
In the past, when I installed Linux Mint - it used UEFI boot mode. When I removed that and reinstalled Windows 8, I was forced to boot from CSM mode because the LiveUSB wouldn't work otherwise. Now, all of my Windows booting is done using CSM. –  Joe Jun 22 at 4:05
    
maybe because you have used the non-UEFI windows install disk or have deleted all partitions so Windows installer didn't know that and messed up the GPT. You have to fix the GPT and use a UEFI 64-bit windows 8 install disk –  Lưu Vĩnh Phúc Jun 22 at 4:26
    
I've fixed the GPT table. See my answer (and question) here: askubuntu.com/questions/486556/… –  Joe Jun 22 at 4:38
    
Instead of reinstalling Windows 8 and recovering the UEFI mode, I've decided to install Ubuntu in Legacy mode. Do you have any recommendations for that? –  Joe Jun 22 at 4:39

Since reinstalling Win8, I cannot boot into UEFI mode. Which is ultimately, I think, affecting my wishes to dual-boot Ubuntu alongside Windows again.

Any ideas as to how to fix this?

I had the same problem on an ASUS Q500A laptop. I was attempting to multi-boot Windows 8, Debian, Fedora and Ubuntu. The idea was to install all the base operating systems first, and then spend the next two days in patching (in case one install blew out earlier install/patch work).

My solution was to install Windows first, and then apply all the Windows patches. After all the Windows patches were installed, I could boot into UEFI and load the other OSes. And the "apply all Windows patches" included the required reboots too. Its not enough to just install the patches.

Without the patches, I could not even get the UEFI boot screen to show. And I tried everything I could find to get to that boot screen - from pressing ESC, F2, F10, F12, etc. I even read the damn laptop manual and the manual on the Aptios Firmware. I could not find the behavior documented anywhere.

Here's a few threads when I was trying to avoid the "fully patch Windows" solution: How to enter UEFI on computer startup (what did Windows change)? from Microsoft Forums and Dual Boot Linux and Windows 8 on ASUS laptop (Windows 8 Installed) from Super User.

And I never was able to determine who was at fault for locking me out of my own system (i.e., UEFI spec requirement, Microsoft logo requirement, Firmware feature, etc).

share|improve this answer
    
When you say UEFI boot screen, do you mean the BIOS settings reached on startup with the F2 or F12 key? Or do you actually mean the UEFI boot menu with the pretty Windows styling reached by Shift-clicking the Restart button? –  Joe Jun 22 at 2:50
    
@Joe - the boot screen offered by the UEFI via <kbd>ESC</kbd> and friends. Its not frills. Not the Windows styled boot screen. For what its worth, I could not get Windows to allow me to boot to the Linux ISOs from the Windows style screens either when patches were waiting. That includes both DVD and thumb drives. They would not show up as a bootable device when patches were pending. –  jww Jun 22 at 3:04
    
In one of the links you gave me, the same mistake was made. The user asked how to get to UEFI boot screen, and the Microsoft professional corrected him that he was trying to get into BIOS. You mean the BIOS settings, which I have no problem getting into. I mean, electing to use UEFI boot mode (vs CSM/Legacy/BIOS boot mode). Whenever I switch to UEFI mode, my system doesn't find a bootable drive. –  Joe Jun 22 at 3:17
    
@Joe - OK, thanks. I could not get into the Firmware's built-in screen to select which partition to boot. Though I could get into the Windows style boot menu, my bootable devices were not present until I applied patches. Here, bootable devices included other partitions, DVD ISOs and USB Thumb Drive ISOs. I hope that clears things up for you. –  jww Jun 22 at 3:23
    
I will look further into the links you provided, thanks for your time. –  Joe Jun 22 at 3:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.