Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My debug log:

ssh -D 5000 root@103.117.102.43 -vvv
OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011
debug1: Reading configuration data /Users/zhenweiliu/.ssh/config
debug1: /Users/zhenweiliu/.ssh/config line 12: Applying options for *
debug1: Reading configuration data /etc/ssh_config
debug1: /etc/ssh_config line 20: Applying options for *
debug1: auto-mux: Trying existing master
debug1: Control socket "/tmp/master-root@103.117.102.43:22" does not exist
debug2: ssh_connect: needpriv 0
debug1: Connecting to 103.117.102.43 [103.117.102.43] port 22.
debug1: Connection established.
debug3: Incorrect RSA1 identifier
debug3: Could not load "/Users/zhenweiliu/.ssh/id_rsa" as a RSA1 public key
debug1: identity file /Users/zhenweiliu/.ssh/id_rsa type 1
debug1: identity file /Users/zhenweiliu/.ssh/id_rsa-cert type -1
debug1: identity file /Users/zhenweiliu/.ssh/id_dsa type -1
debug1: identity file /Users/zhenweiliu/.ssh/id_dsa-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.2
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.0p1 Debian-4
debug1: match: OpenSSH_6.0p1 Debian-4 pat OpenSSH*
debug2: fd 3 setting O_NONBLOCK
debug3: load_hostkeys: loading entries for host "103.117.102.43" from file "/Users/zhenweiliu/.ssh/known_hosts"
debug3: load_hostkeys: found key type RSA in file /Users/zhenweiliu/.ssh/known_hosts:16
debug3: load_hostkeys: loaded 1 keys
debug3: order_hostkeyalgs: prefer hostkeyalgs: ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-rsa
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-rsa,ssh-dss-cert-v01@openssh.com,ssh-dss-cert-v00@openssh.com,ssh-dss
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-sha1,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-sha1,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit: first_kex_follows 0
debug2: kex_parse_kexinit: reserved 0
debug2: kex_parse_kexinit: ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss,ecdsa-sha2-nistp256
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit: first_kex_follows 0
debug2: kex_parse_kexinit: reserved 0
debug2: mac_setup: found hmac-md5
debug1: kex: server->client aes128-ctr hmac-md5 none
debug2: mac_setup: found hmac-md5
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: dh_gen_key: priv key bits set: 126/256
debug2: bits set: 511/1024
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Server host key: RSA 4a:d7:4c:0b:0c:1e:2f:78:f9:dc:ef:e5:29:c7:3f:18
debug3: load_hostkeys: loading entries for host "103.117.102.43" from file "/Users/zhenweiliu/.ssh/known_hosts"
debug3: load_hostkeys: found key type RSA in file /Users/zhenweiliu/.ssh/known_hosts:16
debug3: load_hostkeys: loaded 1 keys
debug1: Host '103.117.102.43' is known and matches the RSA host key.
debug1: Found key in /Users/zhenweiliu/.ssh/known_hosts:16
debug2: bits set: 478/1024
debug1: ssh_rsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /Users/zhenweiliu/.ssh/id_rsa.cn6 (0x7fe09340b5c0),
debug2: key: /Users/zhenweiliu/.ssh/id_rsa (0x7fe093500290),
debug2: key: /Users/zhenweiliu/.ssh/id_dsa (0x0),
debug1: Authentications that can continue: publickey,password
debug3: start over, passed a different list publickey,password
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /Users/zhenweiliu/.ssh/id_rsa.cn6
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,password
debug1: Offering RSA public key: /Users/zhenweiliu/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /Users/zhenweiliu/.ssh/id_dsa
debug3: no such identity: /Users/zhenweiliu/.ssh/id_dsa: No such file or directory
debug2: we did not send a packet, disable method
debug3: authmethod_lookup password
debug3: remaining preferred: ,password
debug3: authmethod_is_enabled password
debug1: Next authentication method: password
root@103.117.102.43's password:
debug3: packet_send2: adding 64 (len 60 padlen 4 extra_pad 64)
debug2: we sent a password packet, wait for reply
debug1: Authentication succeeded (password).
Authenticated to 103.117.102.43 ([103.117.102.43]:22).
debug1: Local connections to LOCALHOST:5000 forwarded to remote address socks:0
debug3: channel_setup_fwd_listener: type 2 wildcard 0 addr NULL
debug3: sock_set_v6only: set socket 5 IPV6_V6ONLY
debug1: Local forwarding listening on ::1 port 5000.
debug2: fd 5 setting O_NONBLOCK
debug3: fd 5 is O_NONBLOCK
debug1: channel 0: new [port listener]
debug1: Local forwarding listening on 127.0.0.1 port 5000.
debug2: fd 6 setting O_NONBLOCK
debug3: fd 6 is O_NONBLOCK
debug1: channel 1: new [port listener]
debug1: setting up multiplex master socket
debug3: muxserver_listen: temporary control path /tmp/master-root@103.117.102.43:22.03MBQJpncB2ft4eB
debug2: fd 7 setting O_NONBLOCK
debug3: fd 7 is O_NONBLOCK
debug3: fd 7 is O_NONBLOCK
debug1: channel 2: new [/tmp/master-root@103.117.102.43:22]
debug3: muxserver_listen: mux listener channel 2 fd 7
debug1: channel 3: new [client-session]
debug3: ssh_session2_open: channel_new: 3
debug2: channel 3: send open
debug1: Entering interactive session.
debug2: callback start
debug2: fd 3 setting TCP_NODELAY
debug3: packet_set_tos: set IP_TOS 0x10
debug2: client_session2_setup: id 3
debug2: channel 3: request pty-req confirm 1
debug1: Sending environment.
debug3: Ignored env TERM_PROGRAM
debug3: Ignored env TERM
debug3: Ignored env SHELL
debug3: Ignored env CLICOLOR
debug3: Ignored env TMPDIR
debug3: Ignored env Apple_PubSub_Socket_Render
debug3: Ignored env USER
debug3: Ignored env SSH_AUTH_SOCK
debug3: Ignored env __CF_USER_TEXT_ENCODING
debug3: Ignored env LSCOLORS
debug3: Ignored env __CHECKFIX1436934
debug3: Ignored env PATH
debug3: Ignored env PWD
debug3: Ignored env JAVA_HOME
debug3: Ignored env ITERM_PROFILE
debug3: Ignored env PS1
debug3: Ignored env SHLVL
debug3: Ignored env COLORFGBG
debug3: Ignored env HOME
debug3: Ignored env ITERM_SESSION_ID
debug3: Ignored env LOGNAME
debug1: Sending env LC_CTYPE = UTF-8
debug2: channel 3: request env confirm 0
debug3: Ignored env SECURITYSESSIONID
debug3: Ignored env _
debug2: channel 3: request shell confirm 1
debug2: callback done
debug2: channel 3: open confirm rwindow 0 rmax 32768
debug2: channel_input_status_confirm: type 99 id 3
debug2: PTY allocation request accepted on channel 3
debug2: channel 3: rcvd adjust 2097152
debug2: channel_input_status_confirm: type 99 id 3
debug2: shell request accepted on channel 3
Linux (none) 3.12.9-x86_64-linode37 #1 SMP Mon Feb 3 10:01:02 EST 2014 x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.

My SwitchySharp config in Chrome 127.0.0.1 5000

Then I visit google and it shows: No data received

Debug log

debug1: Connection to port 5000 forwarding to socks port 0 requested.
debug2: fd 11 setting TCP_NODELAY
debug3: fd 11 is O_NONBLOCK
debug3: fd 11 is O_NONBLOCK
debug1: channel 4: new [dynamic-tcpip]
debug2: channel 4: pre_dynamic: have 0
debug1: Connection to port 5000 forwarding to socks port 0 requested.
debug2: fd 12 setting TCP_NODELAY
debug3: fd 12 is O_NONBLOCK
debug3: fd 12 is O_NONBLOCK
debug1: channel 5: new [dynamic-tcpip]
debug2: channel 4: pre_dynamic: have 0
debug2: channel 5: pre_dynamic: have 0
debug1: Connection to port 5000 forwarding to socks port 0 requested.
debug2: fd 13 setting TCP_NODELAY
debug3: fd 13 is O_NONBLOCK
debug3: fd 13 is O_NONBLOCK
debug1: channel 6: new [dynamic-tcpip]
debug2: channel 4: pre_dynamic: have 0
debug2: channel 5: pre_dynamic: have 0
debug2: channel 6: pre_dynamic: have 0
debug2: channel 4: pre_dynamic: have 2155
debug2: channel 4: zombie
debug2: channel 4: garbage collecting
debug1: channel 4: free: dynamic-tcpip, nchannels 7
debug3: channel 4: status: The following connections are open:
  #3 client-session (t4 r0 i0/0 o0/0 fd 8/9 cc -1)
  #5 dynamic-tcpip (t13 r-1 i0/0 o0/0 fd 12/12 cc -1)
  #6 dynamic-tcpip (t13 r-1 i0/0 o0/0 fd 13/13 cc -1)

debug2: channel 5: pre_dynamic: have 0
debug2: channel 6: pre_dynamic: have 0
debug1: Connection to port 5000 forwarding to socks port 0 requested.
debug2: fd 11 setting TCP_NODELAY
debug3: fd 11 is O_NONBLOCK
debug3: fd 11 is O_NONBLOCK
debug1: channel 4: new [dynamic-tcpip]
debug2: channel 4: pre_dynamic: have 0
debug2: channel 5: pre_dynamic: have 0
debug2: channel 6: pre_dynamic: have 0
debug2: channel 4: pre_dynamic: have 2155
debug2: channel 4: zombie
debug2: channel 4: garbage collecting
debug1: channel 4: free: dynamic-tcpip, nchannels 7
debug3: channel 4: status: The following connections are open:
  #3 client-session (t4 r0 i0/0 o0/0 fd 8/9 cc -1)
  #5 dynamic-tcpip (t13 r-1 i0/0 o0/0 fd 12/12 cc -1)
  #6 dynamic-tcpip (t13 r-1 i0/0 o0/0 fd 13/13 cc -1)

debug2: channel 5: pre_dynamic: have 0
debug2: channel 6: pre_dynamic: have 0
debug2: channel 5: read<=0 rfd 12 len 0
debug2: channel 5: not open
debug2: channel 5: zombie
debug2: channel 5: garbage collecting
debug1: channel 5: free: dynamic-tcpip, nchannels 6
debug3: channel 5: status: The following connections are open:
  #3 client-session (t4 r0 i0/0 o0/0 fd 8/9 cc -1)
  #6 dynamic-tcpip (t13 r-1 i0/0 o0/0 fd 13/13 cc -1)

debug2: channel 6: read<=0 rfd 13 len 0
debug2: channel 6: not open
debug2: channel 6: zombie
debug2: channel 6: garbage collecting
debug1: channel 6: free: dynamic-tcpip, nchannels 5
debug3: channel 6: status: The following connections are open:
  #3 client-session (t4 r0 i0/0 o0/0 fd 8/9 cc -1)

debug1: Connection to port 5000 forwarding to socks port 0 requested.
debug2: fd 11 setting TCP_NODELAY
debug3: fd 11 is O_NONBLOCK
debug3: fd 11 is O_NONBLOCK
debug1: channel 4: new [dynamic-tcpip]
debug2: channel 4: pre_dynamic: have 0
debug2: channel 4: pre_dynamic: have 1064
debug2: channel 4: zombie
debug2: channel 4: garbage collecting
debug1: channel 4: free: dynamic-tcpip, nchannels 5
debug3: channel 4: status: The following connections are open:
  #3 client-session (t4 r0 i0/0 o0/0 fd 8/9 cc -1)

How can I fix this ? thx :D

share|improve this question
    
How did you set up the proxy in chrome? Did you specifically set chrome to use a SOCKS proxy? –  Kenster Jun 28 at 12:23
    
Hi @Kenster. Yes, I do. –  user338950 Jul 6 at 5:03

1 Answer 1

Finally I solved this problem The problem is I set the Chrome proxy setting wrong. I write the proxy host and port in the "HTTP proxy" line. This is wrong. I should write them just in the "SOCKS proxy" line and left the other blank

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.