Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to use the i3 window manager with Xfce on Ubuntu 14.04. I have installed Xfce and disabled the "desktop" and Xfce's wm, and set i3 to autostart as the wm of my choose. I do this in Settings -> Session and Startup.

But one the first workspace it seems that no applications want to load, and i3bar that lists all the workspaces are hidden, but you can see a little of it. Even the Xfce panel won't load on the first workspace. I have tried to start up apps on other workspaces, that works without any problem, and tried to move them to workspace one. It doesn't work. It's only the first workspace that don't work.

This problem seems only to affect Ubuntu, the same setup on Fedora 20 works without problems. The exact same problem appears then i tried to use gnome 3 in Ubuntu using i3 as wm. No applications won't load on the first workspace, but the other works fine.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.