Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Excel Workbook which will be sent to a client and I need to get the thousands and decimal seperators right. I have a Workbook.Open routine which will change to custom formatting (and back on close)

.UseSystemSeparators = False
.DecimalSeparator = ","
.ThousandsSeparator = "."

I also have a bunch of charts, which seem unaffected by this change. How do I convince Excel to display charts with a custom decimal separator?

My approach so far was to use number formatting, but I cannot figure out how to actually REPLACE a separator, instead of displaying it. Is there a way to use . (period) and , (comma) to locate the thousands-separator, but at the same time ommitting to print it?

Is there an alternative Way of forcing chart axis to use the above-mentioned application settings for separators?


share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.