Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on OSX Mavericks 10.9.4 and I'm getting an a message "An error occured uploading to the iTunes store. " when trying to upload an application through the Application Loader app.

I checked in /var/log/system.log and I'm getting the following:

 Application Loader[266]:  Error:
 Java 1.6 or higher is required. Please install Java.

Java is installed and in the console I checked the java version with the following results:

 $ java -version
 java version "1.6.0_65"
 Java(TM) SE Runtime Environment (build 1.6.0_65-b14-466.1-11M4716)
 Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-466.1, mixed mode)

I had installed JDK 7 but manually uninstalled it through the terminal by deleting the folder in /Library/Java/JavaVirtualMachines/.

I've also had just installed 1.6 via this link: http://support.apple.com/kb/DL1572.

In the preference pane Java is showing but clicking on it gives me a message “Java” can’t be opened because it isn’t available. I'm not if this is related or not.

Does anyone have any idea why the Application Loader can't find the Java installation?

Thanks!

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.