Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I used http://jankarres.de/2013/05/raspberry-pi-openvpn-vpn-server-installieren/ for installing openvpn. I followed the instructions to the letter and everything worked fine.

My client connected to the openvpn server and all of its traffic was routed through the openvpn server.

I used this for a few week.

Yesterday I installed samba:

sudo apt-get update
sudo apt-get install samba

Added a folder to /etc/samba/smb.conf.

Samba worked fine inside my local network. Today I connected with my openvpn client to the server and I can only reach my local network.

What workes:

  • Connect to the openvpn server
  • Access Server inside the local lan
  • Openvpn server can ping google.com just fine. Everything works

What's now broken:

  • Openvpn client can no longer lookup dns names
  • Openvpn client can no longer access any source outside the openvpn lan

Openvpn client route:

Ziel            Router          Genmask         Flags Metric Ref    Use Iface
default         11.8.0.5        0.0.0.0         UG    0      0        0 tun0
10.0.2.0        *               255.255.255.0   U     1      0        0 eth0
11.8.0.0        11.8.0.5        255.255.255.0   UG    0      0        0 tun0
11.8.0.5        *               255.255.255.255 UH    0      0        0 tun0
#ExternalIP#    10.0.2.2        255.255.255.255 UGH   0      0        0 eth0

Openvpn server route:

Ziel            Router          Genmask         Flags Metric Ref    Use Iface
default         10.10.16.1      0.0.0.0         UG    0      0        0 eth0
10.10.16.0      *               255.255.255.0   U     0      0        0 eth0
11.8.0.0        11.8.0.2        255.255.255.0   UG    0      0        0 tun0
11.8.0.2        *               255.255.255.255 UH    0      0        0 tun0

Gateway (Router Local lan) 10.10.16.1 Local lan 10.10.16.0 Openvpn network 11.8.0.0

Again: I have changed none of the openvpn settings...

share|improve this question

1 Answer 1

You are using for your OpenVPN network some public, routable addresses (11.8.0.0/24) instead of private addresses. Change these addresses to something private, like 192.168.115.0/24 or 10.171.43.0/24, and check again.

By the way, 11.8.0.5, according to whatismyipaddress.com, corresponds to DoD Network Information Center in Columbus, Ohio: I bet they are quite unwilling to resolve your DNS queries and to route your stuff.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.