Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a gentoo Linux system the dmesg output shows something like the following repeatedly:

eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
eth0: Transmit timeout, status 0c 0005 c07f media 10.
eth0: Tx queue start entry 18  dirty entry 14.
eth0:  Tx descriptor 0 is 0008a5ea.
eth0:  Tx descriptor 1 is 0008a5ea.
eth0:  Tx descriptor 2 is 0008a5ea. (queue head)
eth0:  Tx descriptor 3 is 0008a5ea.
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1

and the output of ethtool -S eth0 is

NIC statistics:
     early_rx: 0
     tx_buf_mapped: 0
     tx_timeouts: 137
     rx_lost_in_ring: 0

However, on an identical system with identical ethernet card and identical Linux and identical kernel there is no such error visible. How to find out the reason for this error message?

Speculation: Could it be some firewall issues, then the Linux system is trying to copy something to a different system? Any other network-related issue?

share|improve this question

1 Answer 1

I have not seen this error message in a very long time. Are you on old hardware/software?

In any way, the trick to make it work is to disable acpi, the Advanced Configuration and Power Interface. Please do not confuse this with apic, the Advanced Programmable Interrupt Controller.

The way to do it is to change the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

into

 GRUB_CMDLINE_LINUX_DEFAULT="acpi=off ro quiet splash"

in (on my Ubuntu system) /etc/default/grub. In Gentoo, I do not know, but I am sure you may find something strictly equivalent.

share|improve this answer
    
Thanks for your suggestion, but I (i) cannot find a file on gentoo which contains the specified line and (ii) I do not see the problem on an identical system, which almost to absolute certainty has the exact same internal Linux configuration (concerning settings for boot, kernel, etc. ) –  Alex Jul 3 at 5:36
    
@Alex Perhaps you are not on Grub? Also: if you really believe the two systems are identical, then no use in asking: the fault lies in the hardware. But are you sure the two systems are identical? –  MariusMatutiae Jul 3 at 7:00
    
I believe this issue to come from the network outside the system. I sometimes see problems when transfering data to an outside server, resulting in a counter increase for ethtool -S eth0. Do you totally disagree, or do you think this could be the reason? The actual systems are identical, but they are used in dfferent places with different network settings (outside of the actual Linux/hardware system). –  Alex Jul 3 at 9:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.