Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have only wireless service on my computer (I cannot physically move it to reach Ethernet).

As I start Linux, I see an error message: (I replaced wlp0... with )

    [FAILED] Failed to start dhcpcd on <mywirelessinterface>. See 'systemctl status dhcpcd@<mywirelessinterface>.service’ for details.

Ok, I do that:

    # systemctl status dhcpcd@<mywirelessinterface>.service

    * dhcpcd@<mywirelessinterface>.service - dhcpcd on <mywirelessinterface>
    Loaded: loaded (/usr/lib/system/system/dhcpcd@.service: enabled)
    Active: failed (Result: resources) since <recent date and time>
    Process: 2918 ExecStart=/usr/bin/dhcpcd -q -w %I (code=exited, status=0/SUCCESS)

    <Current date and time> localhost system[1]: PID file /run/dhcpcd-<mywirelessinterface>.pid not readable (yet?) after start.
    <Current date and time> localhost system[1]: Failed to start dhcpcd on <mywirelessservice>.
    Failed to start dhcpcd on <mywirelesscervice>.
    <Current date and time> localhost system[1]: Unit dhcpcd@<mywirelessinterface>.service entered failed state.

When I start it manually with sudo su:

    # systemctl start dhcpcd@<mywirelessinterface>.service

it fails the same way:

      Job for dhcpcd@<mywirelessinterface>.service failed. See ‘systemctl status netctl@<mywirelessinterface>\x2<mynetworkname>.service’ and ‘journalctl –xn’ for details.

Here is what journal says:

    # journalctl -xn

    -- Logs begin at <date, time>, end at <date, time>. --
    <Current date and time> localhost dhcpcd[4366]: <mywirelessinterface> failed to start wpa_supplicant
    <Current date and time> localhost dhcpcd[4367]: <mywirelessinterface> sucessfully initialized wpa_supplicant
    Line 1062: unknown EAP method 'SIM'. You may need to add support for this EAP method during wpa_supplicant build time configuration. See README for more information.
    Line 1062: failed to parse eap 'SIM'.
    Line 1065: failed to parse network block.
    Line 1072: unknown EAP method 'PSK'. You may need to add support for this EAP method during wpa_supplicant build time configuration. See README for more information.
    Line 1072: failed to parse eap 'PSK'.
    Line 1076: failed to parse network block.
    Line 1108: unknown EAP method 'IKEV2'. You may need to add support for this EAP method during wpa_supplicant build time configuration. See README for more information.
    Line 1108: failed to parse eap 'IKEV2'.
    Line 1111: failed to parse network block.
    Failed to read or parse configuration 'etc/wpa_supplicant/wpa_supplicant.conf'.
    <Current date and time> localhost dhcpcd[213]: <mywirelessinterface>: waiting for carrier
    <Current date and time> localhost dhcpcd[213]: <myotherinterface>: waiting for carrier
    <Current date and time> localhost dhcpcd[213]: control command: /usr/sbin/dhcpcd -k <myotherinterface>
    <Current date and time> localhost dhcpcd[213]: <myotherinterface> removing interface
    <Current date and time> localhost kernel: IPv6: ADDRCONF(NETDEV_UP): <mywirelessinterface>: link is not ready
    <Current date and time> localhost kernel: ieee80211 phy0: rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 10 in queue 0
    <Current date and time> localhost kernel: ieee80211 phy0: rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 10 in queue 0
    <Current date and time> localhost kernel: ieee80211 phy0: rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 10 in queue 0

I did try ip link, iw dev

     ip link set <mywirelessinterface> up

Did not help. I have not played with /etc/dhcpcd.conf yet and I don't know if a wpa_supplicant configuration file exists. I just don't know what they are yet. Help!!!

share|improve this question

1 Answer 1

Basically, it is a problem with wpa_supplicant: the default /etc/wpa_supplicant.conf is basically all about documentation, it is not a valid configuration file. The following is a simple example of a valid file:

 ctrl_interface=/var/run/wpa_supplicant
 ap_scan=1
 fast_reauth=0
 network={
    ssid="WifiNetworkName"
    key_mgmt=WPA-PSK
    psk="WifiNetworkPassword"
    priority=5
 }

You may wish to keep the old version (just rename it to /etc/wpa_supplicant_old.conf, for instance) because it contains many useful examples.

Alternatively, you may make your life much simpler by installing a network manager: there are many, netctl, wicd, personally I prefer NetworkManager. You can find in the Wiki all the instructions you need. Just remember to disable any other service trying to manage your connections for you, you can list all enabled services with the command

  sudo systemctl --type=service
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.