Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know that windows made the welcome noise for turning on your computer iconic, but it's annoying in the middle of a group. I can't seem to turn off my sound before Ubuntu boots up, and I'm guessing that It will be easier to turn off all the boot up noises rather than fixing that.

Also if it matters running Ubuntu 9.10 Karmic Koala

share|improve this question

4 Answers 4

up vote 0 down vote accepted

I'm not able to test this out beforehand, but

sudo rm /usr/share/gdm/autostart/LoginWindow/libcanberra-ready-sound.desktop /usr/share/gnome/autostart/libcanberra-login-sound.desktop /usr/share/gnome/shutdown/libcanberra-logout-sound.sh

should disable all startup-, shutdown-, login-, and logout-sounds systemwide.

A less invasive approach would be to edit the aforementioned files and but a # before the lines that contain canberra-gtk-play. This would mark them as comments, therefore making the system disregard them. This also "protects" you against the system replacing the missing files during an update or similar.

share|improve this answer
    
This is the only one of the solutions that seemed to actually get rid of the drum-beat login-ready sound. Thanks –  Andrew Redd Mar 1 '10 at 0:49
    
I still get a single "beat"/"alert" sound in gdm when I do this, but the drums are gone... –  jdm Jul 17 '12 at 15:47

I haven't switched to Karmic yet so couldn't test it, but I think this thread: http://ubuntuforums.org/showthread.php?t=1313349 should be able to help you.

share|improve this answer

You can turn this off in System > Preferences > Sound. Just select "no sounds" for the theme.

It used to be customizable in 9.04.

You can do something more destructive if you want only that sound removed, but this shuts the computer up entirely (something that's nice for laptops).

share|improve this answer

This had it for the drum beat sound. Found at http://ubuntuforums.org/showthread.php?t=1300051

alt+F2 gconf-editor

untick the active key in order to disable the login ready drums sound in /apps/gdm/simple-greeter/settings-manager-plugins/sound/

That's only half of it. I lost the link to where i found the other half but it looks like turning off all sounds in System > Preferences > Sound will do it. Or more specifically removing the GNOME login sound from the Startup applications in System > Preferences > Startup Applications

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.