Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running on windows 7 and using WAMP for my local development. Now I Install cultbooking in my wamp and can't finish my installation because it says sock "Socket support - Socket not supported". Any Ideas how I can make my socket available? I'm new to web development.


additional info ---------------------------------------------------------------

This is what I did, I download the Cultbooking from the ( and drag the files to my 'www' directory of my wamp. Now when i pointed my browser to my localhost it say

  PHP version >= 5.0 Yes

  zlib compression support Available

  XML support Available

  MySQL support Available

  Socket support Unavailable

  configuration.php Writeable

Now my only problem is my Socket support. How do I enable it? if you're in my shoes, Any Ideas?


share|improve this question
up vote 0 down vote accepted

I'm gonna guess with a quick google search: Cultbooking is this software

Next time I would just put a direct link to it.

But to the point, I'm also assuming this is a PHP application, and guessing socket means it might have something to do with MYSQL (database) connection. Have you configured the database settings for cultbooking?

Without posting some log errors, or actual errors it is overly difficult and only worth guessing in trying to help with a solution.

If you post a log entry we might be able to help more.


Based on your edit/update. Have you tried just enabling sockets in php.ini?


Uncomment ; and leave it as extension=php_sockets.dll then restart Apache. That should be all you need.

share|improve this answer
Thanks for letting me know!. Hope my additional Info helps, Thanks :) – Pennf0lio Dec 4 '09 at 10:04
Thanks Jakub, You're a life saver! It work like charm! Thank You! – Pennf0lio Dec 5 '09 at 0:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.