Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to compile nodejs using MSYS, mingw32 on Windows 7-64

Valentin Golev@VALYASNOTEBOOK /home/Valentin_Golev/nodejs
$ ./configure
Checking for program CL                  : ok C:\Program Files (x86)\Microsoft V
isual Studio 10.0\VC\BIN\x86_amd64\CL.exe
Checking for program CL                  : ok C:\Program Files (x86)\Microsoft V
isual Studio 10.0\VC\BIN\CL.exe
Checking for program CL                  : ok C:\Program Files (x86)\Microsoft V
isual Studio 10.0\VC\BIN\amd64\CL.exe
Checking for program CL                  : ok c:\Program Files (x86)\Microsoft V
isual Studio 9.0\VC\BIN\CL.exe
Checking for program CL                  : ok c:\Program Files (x86)\Microsoft V
isual Studio 9.0\VC\BIN\CL.exe
Checking for program CL                  : ok c:\Program Files (x86)\Microsoft V
isual Studio 9.0\VC\BIN\x86_amd64\CL.exe
Checking for program CL                  : ok c:\Program Files (x86)\Microsoft V
isual Studio 9.0\VC\BIN\CL.exe
Checking for program CL                  : ok c:\Program Files (x86)\Microsoft V
isual Studio 9.0\VC\BIN\amd64\CL.exe
Checking for program CL                  : ok c:\Program Files (x86)\Microsoft V
isual Studio 9.0\VC\BIN\amd64\CL.exe
Checking for program LINK                : ok c:\Program Files (x86)\Microsoft V
isual Studio 9.0\VC\BIN\amd64\LINK.exe
Checking for program LIB                 : ok c:\Program Files (x86)\Microsoft V
isual Studio 9.0\VC\BIN\amd64\LIB.exe
Checking for program MT                  : ok C:\Program Files\\Microsoft SDKs\W
indows\v6.0A\bin\x64\MT.exe
Checking for program RC                  : ok C:\Program Files\\Microsoft SDKs\W
indows\v6.0A\bin\x64\RC.exe
Checking for msvc                        : ok
Checking for msvc                        : ok
Checking for library dl                  : not found
Checking for library execinfo            : not found
Checking for gnutls >= 2.5.0             : fail
--- libeio ---
Checking for library pthread             : not found
Checking for function pthread_create     : not found
 error: the configuration failed (see 'C:\\msys\\1.0\\home\\Valentin_Golev\\node
js\\build\\config.log')

I have gnutils built and installed! I've checked the config.log, and there was a command:

 pkg-config --errors-to-stdout --print-errors --atleast-version=2.5.0 gnutls

I typed it in the console

Valentin Golev@VALYASNOTEBOOK /home/Valentin_Golev/nodejs
$ pkg-config --errors-to-stdout --print-errors --atleast-version=2.5.0 gnutls
Package gnutls was not found in the pkg-config search path.
Perhaps you should add the directory containing `gnutls.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gnutls' found

But,

Valentin Golev@VALYASNOTEBOOK ~
$ $PKG_CONFIG_PATH
sh: c:/msys/1.0/local/lib/pkgconfig: is a directory

Valentin Golev@VALYASNOTEBOOK ~
$ cd $PKG_CONFIG_PATH

Valentin Golev@VALYASNOTEBOOK /local/lib/pkgconfig
$ ls
gnutls-extra.pc  gnutls.pc

What am I doing wrong?

share|improve this question

I've gone down basically the same path with the following exception:

Checking for gnutls >= 2.5.0             : fail
--- libeio ---
Checking for library pthread             : not found
Checking for function pthread_create     : not found
 error: the configuration failed (see 'd:\\Code\\Javascript\\node\\build\\config.log')

config.log basically says it cant find pthread.lib. So after copying pthread.lib into a directory that it lists as a search-able directory I come across yet another error.

--- libeio ---
Checking for library pthread             : ok
Checking for function pthread_create     : ok
Checking for function pthread_atfork     : not found
 error: the configuration failed (see 'd:\\Code\\Javascript\\node\\build\\config.log')

It seems as though pthread hasn't been updated since 2006 and in their release notes they say (ref: http://sourceware.org/pthreads-win32/announcement.html):

The following functions are not implemented:

....

      ---------------------------
      Fork Handlers
      ---------------------------
      pthread_atfork

It is unfortunate!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .