Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Im using Fedora 10 with Synergy from Windows 7

When ever i use my keyboard through synergy and type @ i get the Omega Sign

Any ideas, or someone had similar problems?

share|improve this question
up vote 12 down vote accepted

I had problems with @, <, and >, so I did the following:

Code:

xmodmap -e "keycode 53 = x X greater greater greater greater"
xmodmap -e "keycode 52 = z Z less less less less"
xmodmap -e "keycode 24 = q Q at at at at"

Which solved those three... though I have no idea why the problem occurs in the first place.

share|improve this answer
    
My keyboard on the linux machine works fine, Its on Synergy that it fails. – whoami Dec 2 '09 at 12:00
    
@Systech +1 Nice work around! – nbolton Jan 12 '10 at 5:48
1  
@Systech I just added your work around to our bug tracker. – nbolton Jan 13 '10 at 17:38
    
@nbolton Thanks dude – admintech Sep 24 '10 at 9:57
2  
@nbolton Any chance of an actual fix instead of this workaround? – Danny Staple Sep 17 '14 at 14:59

This is a known issue, and we're working on it right now. There are several work arounds however, so if you take a peek at that issue, you may find something. If you have a Google account, you can star the issue to get a notification when it's fixed.

share|improve this answer
2  
Nick - is there a new link for that bug in the tracker please? – Danny Staple Sep 17 '14 at 12:39
    
here is the link to this issue on the new tracker: github.com/symless/synergy/issues/62 – wes May 1 at 11:42

Create a file ~/.Xmodmap and add the following to it:

keycode 53 = x X greater greater greater greater
keycode 52 = z Z less less less less
keycode 24 = q Q at at at at

You can activate it straight away with:

xmodmap ~/.Xmodmap

I believe this will activate automatically when you reboot - but I hardly ever reboot, so haven't tested this.

Thanks (and +1) to Systech's answer for the contents of the file, and thanks to this page for instructions on how to make it persist across reboots.

share|improve this answer

pobably a keycode translation problem. Have a look at the synergy configuration. You should use the same language settings as locally

share|improve this answer
    
i cant find the synergy config on fedora any ideas? – whoami Dec 2 '09 at 12:01
    
There are two possible locations for the synergy server config file, either ~/.synergy.conf or /etc/synergy.conf - however, this will not help fix the issue, since it's a software bug and not a config problem. – nbolton Jan 12 '10 at 5:47

locate synergy.conf, its probably in /etc

share|improve this answer
    
The synergy server config is also located at ~/.synergy.conf (but modifying the config is unlikely fix the problem). – nbolton Jan 12 '10 at 5:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .