Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to share a Canon printer from Raspberry PI running Raspbian. Unfortunately, the precompiled drivers provided by Canon don't work with the RPi's armhf architecture, and compiling the source seems to be impossible. So, how can I share the printer without having a driver on the RPi itself, and just use the Windows drivers present on the client? I must add, the client(s) is/are running Windows.

I've currently tried adding the Printer as a Raw Printer using the CUPS web interface, and a samba share with the following smb.conf:

[global]
workgroup = WORKGROUP
#usershare allow guests = yes
#security=share
security=user
follow symlinks = yes
wide links = no
unix extensions = no
lock directory = /var/cache/samba
netbios name = PI
load printers = yes
[printers]
comment = All Printers
path = /var/spool/samba
use client driver = Yes
printable = yes
printing = CUPS
public = yes
writable = no
create mode = 0700

But it doesn't seem to work. I can see it and add the printer, but printing itself doesn;t work. The CUPS web interface shows a "Withheld" message everytime I try to print.

So, is my approach correct? Is there another way to do this?

share|improve this question

1 Answer 1

I tried it on odroid arm board with USBIP module. This required client side install printer sever.

Your solution doesn't seem to work as there's no printer driver for arm. Of course if your printer support IPP, you don't need to connect to any ARM board in the first place.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.