Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought a 16GB (4x4GB) set of CML16GX3M4A1600C9B RAM for my system, upgrading from an older 8GB (4x2GB) set that's currently in the system.

Before purchasing, I checked the manual for my Gigabyte H55M-UD2H motherboard, which showed that it takes 16GB max. The notes say that 1666MHz is the maximum for an i3, which is fine as this is 1600MHz. Using Corsair's memory finder tool, I looked up my motherboard and it found the RAM above as compatible. I also made sure that my BIOS was up to date (F11 release) and that I'd done a full round of Windows Updates just to get myself in position for the upgrade.

I bought the RAM, installed it, and found that Windows immediately BSoD'ed at boot. I launched into Memtest86+ (latest version as of last week) and it hung at exactly 26% into test 2. It had properly detected all of the DIMMs with the correct name and latencies, so I figured the RAM was probably dead. It did confuse me a little though, as RAM tends to show up with errors rather than just hard-locking the test. Furthermore, the little red + logo at the top of the screen continued to flash. Despite this none of the interface worked (Esc / C / SP / CR keys).

I tried with individual sticks and got the same issue. I checked the BIOS and the voltage was correctly set to 1.5V, XMP was set to normal (no OC profile), and the clock and timings were all set correctly too.

Installing the old RAM (CMX4G3M2A1600C9) again worked fine, and my system was back up and running just as it was prior to the upgrade, with no issues.

I sent the first set back on an RMA and got a new set, and these are also exhibiting the same problems. Memtest86+ locks up exactly at the 26% mark on test #2, and trying to boot into Windows just gives me a BSoD.

Any idea what's causing this problem, or how I can diagnose it further?


Full specs:

  • Gigabyte H55M-UD2H
  • Intel Core i3 530 @ 2.93GHz (CPUID 20652, rev9)
  • nVidia GeForce GTX 650 Ti BOOST
  • 700W OCZ PSU

Info from BIOS:

  • BCLK: 133.38MHz
  • QPI Frequency: 5868MHz (44X)
  • Memory Frequency: 1333MHz (10X)
  • CPU:
    • Ratio: 22
    • Freq: 2394
    • Temp: ~43C
  • DIMMs:
    • Slots: 4096 / 4096 / 4096 / 4096
    • Total: 16384
    • Channel A: 9-9-9-24, tRRD=4, tWTP=21, tRFC=174, tCMD=3
    • Channel B: 9-9-9-24, tRRD=4, tWTP=21, tRFC=174, tCMD=3
    • XMP: Disabled
    • Performance Enhance: Standard
  • Features:
    • Cores Enabled: ALL
    • Multi-Threading: Enabled
    • CPU C1E: Auto
    • CPU C3/C6 State: Auto
    • CPU EIST Function: Auto
    • Bi-Directional PROCHOT: Auto
  • Voltages:
    • CPU Clock Drive: 700mV [Normal]
    • PCI Express Clock Drive: 700mV [Normal]
    • CPU Vcore: 1.21250V (Auto)
    • QPI/Vtt: 1.100V (Auto)
    • Graphics Core: 1.000V (Auto)
    • PCH Core: 1.050V (Auto)
    • CPU PLL: 1.800V (Auto)
    • DRAM Voltage: 1.500V (Auto)
    • DRAM Termination: 0.750V (Auto)
    • Ch-A Data Vref: 0.750V (Auto)
    • Ch-B Data Vref: 0.750V (Auto)
    • Ch-A Address Vref: 0.750V (Auto)
    • Ch-B Address Vref: 0.750V (Auto)

Note: As I was writing this, I had a few cases of the BIOS freezing up on me too.

share|improve this question
    
It would be useful to find out if another brand would work or whether the chips you have work in another similar system. –  martineau Jul 6 '14 at 15:59
    
Unfortunately I don't have another system that'll take standard non-ECC DDR3. My other box is an older DDR2 board, and my servers all require ECC DIMMs. If I had another set of 4x4GB DDR3 DIMMs that worked in this system, I wouldn't be having this problem! :P –  Polynomial Jul 6 '14 at 16:14
    
If that happened to me, with 2 sets of ram chunks doing the same thing, I would be down there analising the rams socket connections, I wouldnt know why I was doing that :-) I just would. And the CPU socket pins especially. . Next I would set the timing manually and set it to 10-10-10-36 or some such thing manually, or even 13-13-13-36 and at 1333 rate, to somehow determine that no mater how slow it goes it still fails. –  Psycogeek Jul 7 '14 at 8:35

2 Answers 2

There are multiple threads in the MemTest86+ forum about the current MemTest86+ release freezing.

There has also been no updates or bugs fixes for about a year, despite this issue being reported a long time back to the project. So while your RAM might in fact be bad, you can't rule out a false positive from MemTest86+ either.

share|improve this answer
up vote 1 down vote accepted

As per xkcd's mantra I figured it's only fair to post my solution.

I called up Corsair and the guy on the phone worked out the problem immediately - my motherboard's memory controller doesn't support the higher density DRAM ICs found on single-sided DIMMs. The maximum addressing limit per IC on my board is 512MB, which means I can fit 16GB in 4x4GB only if each DIMM splits that down into a double-sided 8x512MB configuration, rather than a 4x1GB configuration.

Annoyingly, manufacturers change this configuration arbitrarily during production depending on the price of components, so you can't guarantee that two sets of RAM with the same product code are actually identical in terms of density.

Corsair don't actually provide a guarantee of this at all (neither do any other manufacturers, for that matter) so you just have to get lucky. However, in this case, they were able to find one product code that was only ever manufactured in dual-sided form, which I'm now using instead :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.