Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7 x64 Home P. OEM I decided to move my Users and ProgramData folders onto my secondary disk to save SSD space. I booted into "repair" mode on the windows DVD. Both drives are NTFS. The drives were assigned different letters to the ones normally used so the commands I ran were:

robocopy /xj /mir /copyall D:Users E:Users
robocopy /xj /mir /copyall D:ProgramData E:ProgramData
rmdir /S /Q D:Users
rmdir /S /Q D:ProgramData
mklink /j D:Users E:Users
mklink /j D:ProgramData E:ProgramData

I then changed the Windows NT ProfileList registry values to point to the new directory (Using the original windows drive letters, not the recovery ones) instead of the system drive, keeping the junctions for any program that relied on using the drive letters instead of the user dir.

After booting back into windows, the login screen displayed "Preparing your desktop" for about a minute until logging onto a basic UI with a message similar to "The user profile service failed". Windows Explorer also threw up something similar to "could not locate C:\Windows\system32\config\systemprofile\Desktop" which seems unreasonable as the rest of the C: drive was not touched at all. I assumed this was because it could not locate the new user profile under what was now D:Users. I logged in to the administrator account (which threw up similar messages) and recreated the junctions on the basis that the ones created under the recovery drive letters may not be interpreted correctly now that the letters are reverted to normal. I then opened the registry and discovered that the values I'd changed had been reset. I then rebooted and the values had saved, but I still couldn't log on properly and received the same "systemprofile" error message.

My question is this: If this is a problem with the registry values and/or junction points, how do I go about rectifying it?

Or if it is due to this C:...\systemprofile\Desktop file being missing, how did this happen and what is the fix?

Or is Windows simply not capable of reading the secondary drive at the pre-login stage (this doesn't make any sense to me but is it a possibility?)

Edit:

After recreating the desktop folder, It becomes clear that this doesn't help my situation as I'm still only getting logged on to the default windows profile (hence systemprofile). It seems after all that is must be a problem with the junction points, registry values or the way windows reads them.

If nothing works by tomorrow, I'll replace the folders and junction the actual profile folder instead of Users

share|improve this question
    
Your problems are indeed because the Desktop folder is missing from the Profile directory. –  Ramhound Jul 7 at 18:46
    
If this sounds stupid let me know, but could I use windows previous versions of the folder to restore it? If it's a meta file (as such) for the profile does it really change? Or is it dynamic and I'd have to generate a new one? –  Jonah Jul 7 at 18:48
    
I just checked and It's not in any of the previous versions of the systemprofile folder - could it be that it isn't needed when the profiles are in the default directory? –  Jonah Jul 7 at 18:50
    
Recreating the Desktop folder brought back the desktop, but I still log on to the default system profile –  Jonah Jul 7 at 19:09
    
If you are still using the default profile that means your system is looking in the wrong location and/or the location is not available when it goes looking for it. –  Ramhound Jul 7 at 19:30

1 Answer 1

up vote 0 down vote accepted

Turns out Windows stores some metadata deep in its user files. I fixed it by Setting the registry values to point to the new location for Users, renaming my profile folder to .bak or whatever, deleting the User account and making a new one with the same name. After a login and logoff (to generate the folder), I went back onto the administrator account and renamed my original folder back to its original name.

This fixed it and now (finally) my SSD can live in peace.

Thanks to Ramhound for the help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.