Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows, you can use the ClicKey program to make click sounds when you type keys. In Mac OS X, you can use KeyClick.

Is there any such program for Linux? I'm using Gnome and Ubuntu 9.10. xset c doesn't seem to work.

share|improve this question

3 Answers 3

This doesn't really answer the question, but I'm going to go out on a limb anyway and suggest that you invest in a quality, buckling spring keyboard. That way, not only do you get the nice clicky-sound, but you get the robustness and "feel" that only come with that type of construction.

They are still being made, in beige and black, with and without "Windows" keys, and with USB connectors. Google is your friend.

I use them daily on Windows and Linux machines, and have never had a problem. I don't own a non-ADB Mac, so I can't say how they work there.

Happy clicking.

share|improve this answer
    
Heh - that's what I did a couple weeks ago. I had originally put this question up to try to figure out if I would like a buckling-spring keyboard! –  Jim Hunziker Jan 5 '10 at 12:05
    
Too funny; I learned to type on an IBM Selectric, and so have always loved the buckling-spring feel. When I found I could still get one, especially since I was working as a coder at the time, I bought a few. The only thing I use "modern" keyboards for, now, are FPS video games. –  Adrien Jan 5 '10 at 19:29

Look at the Gnome Accessibility options. Read the section on "Keyboard Accessibility Audio Feedback"

share|improve this answer
    
I did, but on the real system, those checkboxes are grayed out. –  Jim Hunziker Dec 2 '09 at 19:48
    
I got them enabled by turning on Slow Keys, but there's still no sound. –  Jim Hunziker Dec 2 '09 at 19:58
    
Do you have a non-Pulse driver you can use? Sometimes the older (alsa, analog, etc) work when pulse gives trouble. –  DaveParillo Dec 3 '09 at 23:29

OK... buyer beware; this is a total guess.

Try this:

  • add yourself to the 'pulse_access' group
  • log out and back in
  • see if xset c works then

I can't get keyclick working either (i.e. xset c 100 didn't work for me either) and I wanted to share this before trying steps 2 and 3 above.

Hope this helps (us both!)
-pbr

EDIT: http://wiki.archlinux.org/index.php/PulseAudio leads me to believe it's the pulse_access group not the audio group; additional steps may be needed as well. The switch to pulseaudio seems to have introduced a few wrinkles, huh?

share|improve this answer
    
Tell me about it. Pulseaudio has been a huge headache for me for a while! I keep hoping I'll find that the next release will have pulseaudio-enabled everything, and that never is the case. –  Jim Hunziker Dec 3 '09 at 14:09
    
That didn't seem to help, though the group is called pulse-access, not pulse_access. –  Jim Hunziker Dec 3 '09 at 14:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.