Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently trying to run Chrome OS in VirtualBox 3.0.1. Windows XP Pro is the host system.

The actual behavior is Chrome OS starts up fine, reaches the login screen.

Once so, when trying to log using my Google account, I have the network indicator (at the bottom of Virtual Box window) briefly flashing, showing a connection attempt. Nothing happens then, the display stays on the login screen.

The fact that the network indicator flashes makes me think this may be a proxy configuration issue. Indeed, I'm using a proxy to access the Internet from Windows. I guess such a proxy should be configured for Virtual Box as well, but couldn't find anything on the Internet not implying an actual modification of the guest system (for instance, this kind of solution isn't working for me, as it implies accessing to the guest system, what I can't)...

Does anyone have any clues or ideas on how to configure Virtual Box (and maybe Windows XP) to have this working?

Chrome OS version: 999.999.32409.000656, Developer Build Fri Nov 20 00:07:42 UTC

share|improve this question
add comment

3 Answers

up vote 5 down vote accepted

This isn't a VirtualBox (or Windows XP) problem - you need to instruct Chrome OS to use a proxy. The virtual adapter in VirtualBox can be configured to Bridged or NAT, though NAT would probably simplify your life somewhat.

I don't have a Chrome OS VM - so this part is just a guess based on my Chrome browser, but can you click on the wrench icon -> Options -> Under The Hood (tab) -> The under the network section, click the "change proxy settings" button?

There may also be a way to export the right environment variables (http_proxy most likley) in your startup scripts, as Chrome OS shares a certain legacy with Linux and Ubuntu, but I can't comment specifically on it.

Side Note: Your VirtualBox version is a bit out-dated, have you considered upgrading?

share|improve this answer
add comment

If your virtualbox network adapter is set to NAT at the moment, try setting it to "bridged" and make sure your host OS has made a connection through the proxy to the internet before launching the virtual Chrome.

share|improve this answer
    
Actually tried the connection bridged, didn't work. What did you exactly mean by "your host OS has made a connection through the proxy to the internet", does XP have some proxy settings somewhere at the OS level? I usually configure my firefox settings rather than OS ones to access the Internet. Is there something I'm missing here? –  Loic Dec 8 '09 at 3:07
1  
Go to the control panel, "internet properties", then "connections". You can set proxy preferences under "lan settings". These settings are often used by applications that don't have their own options for proxies. If your proxy uses some form of windows integrated security to validate you, you may need to connect to the internet from some app that is aware of this first, to get validated. –  Console Dec 8 '09 at 8:43
add comment

To set Proxy Configuration In virtualBox

File -> Preferences->Proxy Settings->

IP and Port Number

Then OK

share|improve this answer
    
This is only used for the tasks like downloading guests additions and checking for updates. –  fikovnik May 16 at 13:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.