Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A friend has an HP Pavilion laptop running Windows 8 and there is something that causes it to do nothing if you type a quotation mark until you type the next character, at which point it displays the quotation mark and the other character.

This happens in e.g. Firefox, Notepad, cmd.exe etc. and with both the single and double quote characters.

I don't know what causes this and am having trouble searching for information on this behaviour.

How do I turn off this annoying behaviour?

Edit: Sorry, right after posting this I did some more searching and found this: My windows keyboard is being "clever" with the quote keys - how can I stop it?

share|improve this question
    
Sounds like a bad keyboard try a USB keyboard –  Ramhound Jul 10 at 21:18
    
@Ramhound thanks, but I've found it's because of the "United States-International" input method. –  Wodin Jul 10 at 21:25

1 Answer 1

up vote 1 down vote accepted

This is the default behavior for some international keyboards. If you follow the quote with a vowel it will add an accent mark on that vowel. You can also use the right Alt key as a modifier for entering characters like ñ or ¿.

To change keyboards, go to: Control Panel (Win-X, P) -> Clock, Language, and Region -> Language. Select the language you are currently using and go to Options. Make sure your input language is US and not US-International or something like that.

To switch between keyboards (from within the same language), use Ctrl-Shift. To switch between languages, use Alt-Shift.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.