Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I place my PC to sleep, it goes to sleep for 2 min and then wakes up again on its own.

I ran cmd.exe as an admin and then typed powercfg -last wake and -requests and I got nothing really that can direct me to figure this out. Any other suggestions? I've disabled many devices from waking the system up already including the keyboard (but not the mouse).

C:\Windows\system32>powercfg -lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 0

C:\Windows\system32>powercfg -requests
DISPLAY:
None.

SYSTEM:
None.

AWAYMODE:
None.
share|improve this question
    
When it happened to me it was the network card. No answer, since I don't remember exactly what I did, but I spent some time in device manager looking for options like "allow this device to wake the computer" and disabling them. – Steve Jessop Jul 13 '14 at 17:37
    
Ahhh, even your question might contain the answer for my really frustrating problem that I haven't been able to solve. I hadn't heard of powercfg -requests, but when I just ran it, I saw Plex Media Server.exe listed in SYSTEM and AWAYMODE. I bet my Roku is somehow waking up my Windows 10 PC via Plex. – Ryan Apr 22 at 14:58

11 Answers 11

It could be a Ghost. Or a demon.

Some things that caused this same issue for me were:

  1. I had a very sensitive mouse and even though I was in bed, the mouse would move just very slightly but not noticably, and that woke the PC.
  2. I have also had a problem with USB devices (keyboard/mice/Wireless adapters). Sometimes, and usually over a period of several years, the ports on the PC will become loosened - or something, causing the USB device to move around a little if the desk gets knocked. This caused the PC to play the "USB device removed and inserted" sound and it also caused my PC to wake from sleep.
  3. Check out your Scheduled Tasks. You're bound to have a few if you're not the type to manually delete them all. If updates are cheduled to run in the background this could also be waking your pc. Look out for Google, Apple, Adobe and Java in particular. I always see them in Task Scheduler. And somehow Google update keeps reappearing.
share|improve this answer
    
Also, check this link: howtogeek.com/howto/windows-vista/… – jay_t55 Jul 13 '14 at 16:13
1  
I have a PC which does the same thing with Google chrome installed on it. It checks for updates every 15 minutes, and thus waking the PC. Google also always tries to revive itself with any service you have installed from them. – Mixxiphoid Jul 14 '14 at 6:23
1  
I have a Razer Naga mouse that has a dock for charging, it would wake my Winblows PC by just putting the mouse in the charging dock and other random actions, even just moving it. Disabling the waking permissions in the hardware manager helped. – TC1 Jul 14 '14 at 13:52
1  
Thanks, I will check into Google Chrome's settings since I do use it often, – Peter A Jul 14 '14 at 15:20
2  
One of the big things with scheduled tasks is to look to see if they have the "Wake the computer to run this task" option set in their settings. That's where you'll know that it was the one. – Nick Jul 17 '14 at 20:50

There is a certain event in the Event Viewer that may help you troubleshoot spurious wake-up issues. You can find it under Windows Logs > System; look for "Power-Troubleshooter".

Wake Source Event

However, as you see, it's not always helpful. Mine shows "Unknown" even though I woke it up using the power button.

As an IT admin, I can tell you that spurious wake-ups are difficult to diagnose and solve. There are usually a few per 100 computers experiencing spurious wake-ups even though they all have identical hardware and peripherals.

Hopefully your issue is simply caused by a USB device or network connection or such.

share|improve this answer
    
It could be a loose USB port that is causing this. I don't know. My Event Viewer says the device that is causing the reawake is "unknown" so I need to investigate this further by unplugging and replugging some USB devices one by one. Thanks for the info. I'll let you know how it turns out! – Peter A Jul 14 '14 at 15:21
    
Steam wakes/prevents sleep on my computer because it hooks the auto and fails to let go of it. The only thing that works is to close Steam when I am not gaming... – TheXed Jul 16 '14 at 14:36

Tricky one. Last time I had this, it was a new motherboard with a Realtek network card. These have a "wake on any packet" set, which is annoying.

Go to the network adapter properties, power management tab and tick the "Only allow a magic packet to wake the computer". For me, no more waking up at random. Realtek need a ticking off for that one.

I think it did say the waking was due to the network card, but its one place to look. Next: remove all usb devices and see if that helps.

share|improve this answer
    
I did this for my Realtek PCIe GBE Family Controller and no luck. – Peter A Jul 14 '14 at 15:28
    
My problem was exactly as the original poster described, and this fixed it. It seems any network traffic at all was waking my computer, which is why it could only stay in standby for a few seconds. – user1325179 Jun 8 at 15:38

Simple disable Allow Wakeup Timers or some thing lime that in Control Panel > Power Options > Advanced Power Settings.

Otherwise, if it doesn't work, you may need to go to device manager and, for each device, go to properties and then the power options tab (Not all devices have this).

Here, you should find some checkboxes like "Allow the computer I turn off this device to save power" or "Allow this device to wake up the computer" Depending on the checkboxes checked by default, you should be able to tell if it could be the culprit.

To prevent it from waking up your computer, rather disable "allow this device to wake up this computer", or enable "Allow the computer to turn of this device to save power"

Hope this helps, and sorry if it wasn't too clear, I'm writing from my iPhone.

share|improve this answer
    
For the record, just disabling Wake timers for all power policies in the control panel does absolutely nothing, at least on Windows 10. Both various Scheduled Tasks (UpdateOrchestrator\Reboot) and USB devices will refuse to respect this setting. – seagull Sep 14 '15 at 14:24

I had the same problem with Intel Smart Connect which as sole purpose has to wake up the pc every 15 min. It got installed through some updater program. Just remove it.

share|improve this answer

Hmm... I did some research on the internet and found a little bit out about your problem. It could be:

  • a rusty connection on the USB port or
  • a program or background service (which is hard to find out if it is)

I wonder if running the command: powercfg -devicedisablewake would help.

I haven't really tried this but it is just a suggestion.

If you want another cool way to lock/sleep your computer, check out keylemon (Google it).

share|improve this answer
    
This is giving me an error message. But I'll investigate further, thank you. – Peter A Jul 14 '14 at 15:32

I remember having the same problem with my PC years ago and after a little research, found that Windows Media Center was waking my PC up to download TV scheduling information!

share|improve this answer
    
I've disabled that a while ago and just checked and it's still disabled so I don't think that is it. – Peter A Jul 19 '14 at 17:39

This may sound unbelievable but my touch screen was "unsleeping" itself when I was not around and the desktop items were often moved when I returned. The culprit? FLIES! walking on my screen and playing havoc.... I had to disable the touch feature over summer when they were more prevalent.

share|improve this answer

To add a rather unique wake-up problem to what others already mentioned:

Whenever I mess with electricity in the house, doesn't matter if it's switching something on or off, my computer would wake up. Yeah, standby mode is not an option for this guy.

I verified that it is the electricity causing this, though the reason may very well be my UPS which is connected to the PC via USB for configuration, logging and emergency shutdowns (it supports wake-ups, but I turned them all off).

In short: over-sensitive UPS is an option.

share|improve this answer

In my case, moving this mouse did not wake the PC up from sleep, but did turn the monitor back on, if only the monitor was asleep, which I personally like as a setting. Clicking the mouse or keyboard wakes the PC from sleep. Again, I like this setting. Some of the recommendations to turn off Allow this device to wake the computer in device manager would prevent these clicks from working, especially disabling it for all USB devices (if your mouse and/or keyboard is USB).

I found @ntoskrnl's answer the best. What's below was found in the event viewer with source = Power-Troubleshooter

On my HP EliteDesk 800 G1 (g5r46ut) when the UBB mouse/keyboard woke the PC with click the "Wake Source" was Device -Intel(R) USB 3.0 eXtensible Host Controller For my problematic wake-ups--every 5 minutes literally--the "Wake Source" was Device -Intel(R) Ethernet Connection I217-LM which would be the ethernet LAN port.

Using devmgmt.msc the Power Management tab for this driver had many options. I list the relevant ones to unwanted wake-ups, and what I did, below:

Power Saver Options

  • Respond to ARP requests without waking system (was checked, I left it checked)
  • Respond to NS request without waking system (was checked, I left it checked)
  • Wake on magic packet from power off state (was checked, I left it checked; I might want to do this; most probably would not)

Wake on LAN

  • Wake on Magic Packet (was checked, I left it checked; this is an older, standard way to power on PC's remotely; I might do this, so I left it on; most might never need this)
  • Wake on Pattern Match (was checked, I UN-CHECKED; this was the key to fixing my problem; the help text says it wakes the PC on a received packet matching a specific pattern determined by the OS)
  • Wake on Link Settings (was un-checked, I left it un-checked; the help text said this wakes a APM (Advanced Power Management) PC when a network link is established)

So when i un-checked wake on pattern match my PC went from waking every 5 min to staying asleep all night. I am curious as to what is sending that pattern-matching packet. Another of my Windows OS PC's (Windows 7 and XP)? a smartphone? Router? Switch? My IPS? Host intrusion attempt from internet?

FYI: I found the following article while searching and found it pretty comprehensive (repeating many ideas on this page) with some nice how-to instructions How to Fix a Computer that Keeps Waking Up

share|improve this answer

I had this problem on my ASUS Z87 motherboard and the issue turned out to be related to my LAN card and a "wake on LAN setting." Sometimes your LAN card will wake your computer even if it is shutdown!

If you have an ASUS motherboard I can guide you through the process to fix it. If not check for any settings related to "wake on LAN."

share|improve this answer
    
I've already set the LAN Card not to reawaken my PC but to no avail. – Peter A Jul 19 '14 at 17:38
    
Please fill out the rest of this answer or remove it - What's the point of writing an answer and asking if they would like you to give the information needed? I have this z87 motherboard and this problem has plagued me for years, never figured it out. – miR Feb 12 at 18:29

You must log in to answer this question.

protected by nhinkle Jan 17 '15 at 0:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .