Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can tell by eye that my monitor is running at 1920x1080, but I want to confirm that it is running at 60hz. However, running xrandr gives the following output:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080       0.0* 
   1024x768        0.0  
   800x600         0.0  
   640x480         0.0  

So it recognizes the screen and resolution properly, but for some reason it doesn't know about the refresh rate.

Note: I just installed a fresh copy of debian stable (wheezy). I did not include a desktop environment, so don't assume I have all the standard graphics libraries. I manually installed xorg xcb libxcb-util0-dev libxcb-ewmh-dev libxcb-randr0-dev libxcb-icccm4-dev libxcb-keysyms1-dev libxcb-xinerama0-dev and am running bspwm as my window manager.

I tried booting into tails (which has many, if not all, of the standard graphics packages) and had the same problem though. It recognizes the resolution but says 0.0 for the framerate.

How can I figure out what refresh rate I'm running?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Most likely you are using the wrong driver. You should do a

  lspci -vnn 

and search for VGA display and controller, see which driver (if any) you are using. For instance, for use with Intel hardware, you should download and install the package xserver-xorg-video-intel, for which the package man page states

This package also provides XvMC (XVideo Motion Compensation) drivers for i810/i815 and i9xx and newer chipsets.

This is meant only as an example, you must find the driver appropriate to your hardware.

EDIT:

The output of the above command for me is:

 00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics  Controller (rev 09) (prog-if 00 [VGA controller])
    Subsystem: Toshiba America Info Systems Device 0003
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 45
    Region 0: Memory at e0000000 (64-bit, non-prefetchable) [size=4M]
    Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
    Region 4: I/O ports at 3000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915

As you can see, it states the driver in use. Yours should do the same.

Also: yes, 8086:0412 is the code with which you should search for the driver, but I'll spare you the effort: if you try i915, you will find:

   $ modinfo i915 | grep 8086 | grep 0412
     alias:          pci:v00008086d00000412sv*sd*bc03sc*i*

so i915 is the driver for you. Is it loaded? Try

   lsmod | grep i915

If you have a loaded driver, then you should create an xorg.conf file: the Debian Wiki is quite explicit:

If xorg.conf is missing for some reason, Xorg will probe your hardware on every startup. Though this works fine in most cases, some settings remain inaccessible.

You do this simply, as follows: first, stop all window managers, if you have any (gdm? kdm? lightdm?...), then issue:

  cd /etc/X11/
  Xorg -configure
share|improve this answer
    
I am using HDMI, not VGA, does this matter? The only VGA controller is this 00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell Integrated Graphics Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller]). Is the 8086:0412 what I should be looking for drivers for? –  nullUser Jul 14 at 19:35
    
@nullUser It seems to me that since you have Intel graphics you should install xserver-xorg-video-intel as the above post says. –  BenjiWiebe Jul 15 at 1:51
    
I already had xserver-xorg-video-intel installed. –  nullUser Jul 15 at 3:05
    
@nullUser Please see my edit. –  MariusMatutiae Jul 15 at 5:39
    
@MariusMatutiae Indeed, I see the i915 driver is in use. I did the Xorg -configure from terminal (not terminal emulator), but I didn't have permission without sudoing. I went ahead and ran the command as root, and the command created /root/xorg.conf.new. If this isn't what was supposed to happen let me know. Meantime, see my answer. Everything works as expected now. –  nullUser Jul 15 at 20:30

I upgraded to debian Jessie and the problem disappeared. This makes me think that it was simply that Wheezy doesn't support newer technology.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.