Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have some files stored on this blackberry that I would like to load onto our OpenSolaris machine. When I plug the blackberry into the machine via USB it does not mount like a conventional USB thumbdrive would. It mounted so easily in Windows...

To the best of my knowledge it is on usb9/1 and is identified as a blackberry to the machine

I tried rmmount to no avail, and /rmdisk is empty...

Thanks!

share|improve this question

2 Answers 2

up vote 0 down vote accepted

On the Blackberry, navigate to Settings -> Options -> Media Card and set Media Card Support and Mass Storage Mode Support to On. After you plug it in, it may even automatically mount for you. If it doesn't auto mount, you'll have to do it manually. Check out how to Mount a USB device under Solaris.

share|improve this answer
    
This ended up being the solution, additionally I also had to set "Auto Enable Mass Storage Mode When Connected" to "Prompt" from "No" and almost immediately it showed up as BLACKBERRY. –  0x808080 Dec 7 '09 at 22:53

OpenSolaris doesn't use /rmdisk but /media. Have a look there for your filesystem. If nothing appears, make sure the filesystem used is supported (i.e. that is is FAT unless you add support for NTFS or whatever). Have also a look at the system messages (dmesg) for errors if nothing shows up, that might be due to unexpected inconsistencies.

And by the way, if you want to mount manually, use Solaris device names (eg: /dev/dsk/c9t0d0p0:1), not Linux ones (eg: sdb1) and FAT filesystem type is pcfs, not vfat.

It's quite annoying not being able to comment yet on other replies. :-( The Solaris 10 link posted elsewhere contains inaccuracies and advices that do not apply at all to OpenSolaris.

share|improve this answer
    
Thanks for this reply, I was wondering about this as well, had the above not worked. –  0x808080 Dec 7 '09 at 22:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.