Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The linked directory in this github repository contains a file chinese.svg that I originally made using inkscape on a linux machine. The drawing contains Chinese characters. If I open it on my current linux machine, the characters are garbled: they appear as a random mixture of Latin characters and punctuation. The correct rendering is shown in the file chinese.pdf in the same directory. There is no error message from inkscape when I open the file.

Any suggestions on how to diagnose and fix the problem? The first thing that occurred to me was that maybe I used to have a certain font on my machine that I don't have installed now. However, I can't find any reference to a particular font in the SVG source code, which just seems to have Font-family:Sans (see line 3):

<text
   xml:space="preserve"
   style="font-size:14px;font-style:normal;font-weight:normal;line-height:125%;letter-spacing:0px;word-spacing:0px;fill:#000000;fill-opacity:1;stroke:none;font-family:Sans"
   x="97.14286"
   y="338.07648"
   id="text2985"
   sodipodi:linespacing="125%"><tspan
     sodipodi:role="line"
     id="tspan2987"
     x="97.14286"
     y="338.07648">弗雷德拥有两个可爱的</tspan><tspan
     sodipodi:role="line"
     x="97.14286"
     y="357.02667"
     id="tspan2989">小猎犬和一个超重的猫</tspan></text>

Or is it possible that this is a regression introduced by a certain version of inkscape? I'm using inkscape 0.48.4 r9939 (Jan 22 2014) on Linux Mint 17.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.