Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just bought a Corsair Vengeance K70 which comes with four media keys: stop, skip (forward and backward), and play/pause. The problem is they don't work. I can only use them when either the Services window (through Computer Management, Task Manager, or services.msc, Curse Voice, Logitech Gaming Software, or Gigabyte Force is open and the selected window.

My HID Service is set to Automatic (Trigger Start) and is running. Media keys also don't work when the HID service is disabled.

I've tried closing all open programs as well as unplugging all extra hardware, none of which helps. I've also tried different USB ports.

This is also after a fresh install of Windows 7. Any ideas?

Programs confirmed to work:

  • Ccleaner
  • Computer Management
  • Gigabtye Force
  • Logitech Gaming Software
  • MSI Installers
  • Services
  • Task Manager
share|improve this question
up vote 4 down vote accepted

Turns out the Google Music Chrome extension was the cause of this.

Case closed.

share|improve this answer
1  
Indeed. Go to Settings -> Extensions and then disable Google Play Music – Konsalik Sep 12 '14 at 9:56
2  
I've been looking all over the place for the cause of this frustrating problem - Google Play Music was also the source. Thank you! – Scott Kaye Mar 7 '15 at 3:49
    
I have this issue as well, but I don't have Google Music Chrome extension installed. Any ideas? – Marcus Ekwall Feb 22 at 13:37
    
@MarcusEkwall Best bet would be to start closing programs one at a time and testing between. Once you find the program that's hijacking your media keys, it's easier from there. – DarkWolffe Feb 22 at 18:35
1  
@DarkWolffe I figured it out! The Plex extension had its "Keyboard shortcuts" set to Global. Setting them to In Chrome solved the problem. – Marcus Ekwall Feb 23 at 13:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.