Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows 7 32-bit Professional only allows solid colors on the desktop wallpaper. Any image selected won't be applied.

I've already tried the process described in the other SuperUser question (uncheck Remove Background Images on Ease of Access Center).

I've tried using REG ADD "HKCU\Control Panel\Desktop" /v WallPaper /t REG_SZ /d "path_of_image.jpg" /f and it didn't work.

Also, I've read that Remote Access software can cause issues with the desktop wallpaper, but I haven't checked if that's the problem.

Another strange thing I noticed is that whenever I try to change the image, an "a.jpg" appears as selected. I've found that file at C:\ and it contains the Harmony default wallpaper. Is it possible that a script or software is setting the wallpaper to that file? Is it safe to delete it?

Thanks in advance.

share|improve this question
    
This link looked promising-- social.technet.microsoft.com/Forums/windows/en-US/… –  jAce Jul 16 at 18:46
2  
Is your computer a member of a domain? There may be a Group Policy overriding your settings or preventing them from taking effect. –  Iszi Jul 16 at 20:53
    
@Iszi - Would you like to add that as an answer? The OP confirmed that this fixed the issue. –  Robotnik Aug 31 at 23:56
    
Please don't add "[solved]" to the title. Instead, accept the answer to remove this question from the Unanswered list. –  deleteme Sep 1 at 4:11
    
@damryfbfnetsi - Actually, a single upvote on an answer is enough to remove it from the unanswered list. Acceptance just means that the answer 'worked for the OP'. –  Robotnik Sep 1 at 5:13

1 Answer 1

up vote 1 down vote accepted

If your computer is a member of a domain, or has a Group Policy applied locally, you may not be able to change the wallpaper via the normal dialog or manual Registry edits. If you are not the person primarily responsible for maintaining the system and administering policy on it (in which case you would presumably be aware of this configuration and how to alter it), you should not try to change this. Remember, computers you use at work belong to the company - not you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.