Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know how to change the default application for opening files. I select a file in Finder, right-click and select Get Info from the context menu. In the file's Info window, expand the Open with: panel. In that panel is a combo box that says, in my case, Adobe Flash CS4. I click the combo box and select Flash Player. It changes. Then I click the Change All... button. A dialog pops up and says:

Are you sure you want to change all similar documents to open with the application “Adobe Flash CS4”? This change will apply to all documents with extension “.swf”.

Cancel/Continue

Well, clicking Continue does exactly what the message says. It sets the Finder to open all swf files with Adobe Flash CS4. What is going on? Why doesn't the message say, .... "Flash Player"

share|improve this question

3 Answers 3

A more finely detailed way to designate opening apps according to file suffix: Rubicode - RCDefaultApp.

I don't know for sure if launch services handles the application selection in Get Info (it does in the right click menu "Open with"), but you can delete the launch services pref file in Home/Library/Preferences/com.apple.launchservices.plist and reboot in order to rebuild launch services. That will give you a clean inventory of applications that are available for selection.

share|improve this answer
    
You can also rebuild the LaunchServices database with the command line without rebooting: macosxhints.com/article.php?story=20071102084155353. –  Lawrence Velázquez Dec 4 '09 at 5:59

The answer is simple - Adobe Flash CS4 does not come with a separate player as it does on the windows version. You can download a standalone player such as iSwiff or Adobe's own standalone player for mac (unfortunately supported only up to version 9).

If these don't do the trick, there are plenty of other players available online. Just google 'standalone flash player mac'.

Good luck!

share|improve this answer

Michael,

This has been bugging me for months, too. I think it's a bug in OS X.

It seem that if you change the default application then try to "Change All", OS X forgets that you just changed it, and sets it back to the original.

Instead, do this:

  1. Get Info
  2. Select new default application
  3. DON'T click "Change All"
  4. Close info window
  5. Do Get Info again
  6. Click "Change All"
  7. Click "Confirm"

I'd be interested to hear if this works for anybody else. Our corporate voicemail system converts voicemails to .wav files and e-mails them to me, but when I double click to listen it opens iTunes and saves the voicemail in my music library!! So frustrating!! The trick above finally seems to have solved this problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.