Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is it possible to update python without root access, this is the first time using red hat linux (any linux for that matter) and the default version is python 2.3 which breaks some of my code that i tested on python 2.6.

i tried building from source but it said i needed root access.

share|improve this question

migrated from stackoverflow.com Dec 3 '09 at 19:45

This question came from our site for professional and enthusiast programmers.

    
For what exactly is it needing root access? You should be able to make and make install python as long as you stay in your $HOME-dir. – halfdan Dec 3 '09 at 11:24

How did you compile the source? If you did ./configure, do this instead:

./configure --prefix=$HOME
make
make install

($HOME should expand to something like /home/burisum.) In this way the third step (make install) will install the files in your homedir and you will not need root access.

share|improve this answer
    
i tried this but i get the message, permission denied – burlsm Dec 3 '09 at 12:14
    
Can you show that error message and some (say, 5) of the lines before it? – Stephan202 Dec 3 '09 at 12:19

You can make a "user" installation i.e. in your ~ directory.

Make sure you update your .bashrc (or equivalent) to insert the path to your interpreter in front of /usr/bin if you intend for your interpreter to serve as default for your session though.

share|improve this answer

If you are looking to have access to the latest python modules without harming your system I would suggest using Anaconda. This contains the latest python interpreter etc... It installs in your home directory so that you have access to it and you don't need root permissions to use or install it.

I would let system update handle the systems package update process and not try to force anything (unless you just forgot the root password)

share|improve this answer

You must log in to answer this question.