Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using MacBook Pro (Mac OS X 10.5). On the status bar, check I click the Wireless icon, it said 'Open Network Preferences' And then in the Network Preference, I click 'AirPort' tab, the status said 'Inactive' But the 'Turn AirPort on' is disabled and the Network Name is disabled as well.

I have unlocked the preference pane as well.

So how can I turn on Airport?

Thank you.

share|improve this question
    
Can you take a picture of your Network Preferences page? <kbd>Command+Shift+4<kbd> then <kbd>Space</kbd> will take a picture and save to your Desktop. –  Andrew Flanagan Dec 3 '09 at 23:44
    
(Drat it -- keyboard glyphs don't work in comments I guess. That's Command+Shift+4 then Space bar –  Andrew Flanagan Dec 3 '09 at 23:46

2 Answers 2

Is the lock at the bottom left of the Network Preference Pane window unlocked? Sounds like you may have locked it instead of unlocking it.

If you go to Apple menu --> About this Mac --> More Info... and click on AirPort card does it show you the type of card or does it indicate that you don't have an AirPort card?

Edit: There really isn't an explanation other than something is wonky in that profile-not your fault. You can use the HOME location you've created and all should work fine. If you'd like to clear out your network settings to get wireless working in your Automatic location you will can do that by:

  1. Make note of what your network and energy saver settings are by taking screen shots. Make note of locations, VPNs you have set up, timers for turning on comp, etc.

  2. Navigate to the directory /Library/Preferences/SystemConfiguration Note that this is the Library at the root of the drive, not in your user folder.

  3. Copy that folder to your desktop as a backup. You will have to authenticate as an admin user.

  4. Delete the entire SystemConfiguration folder. It will contain about 8 files. You will have to authenticate again.

  5. Reboot the computer.

  6. Set up your network and energy saver to your liking again and you should be good to go. You will have to manually join each wireless network again as you come across them, but this procedure does not remove any saved passwords for WiFi networks—they are still in your keychain.

share|improve this answer
    
Yes, I have unlocked the Network Preference. And I do have AirPort card: Wireless Card Type: AirPort Extreme (0x14E4, 0x8D) Wireless Card Locale: USA Wireless Card Firmware Version: Broadcom BCM43xx 1.0 (5.10.91.21) Current Wireless Network: AirPort is currently turned off –  hap497 Dec 3 '09 at 20:35
    
Can you create a new location and see if it works there? Where it says "Location: Automatic" click on Automatic and then Edit and then + to create a new location. –  ridogi Dec 3 '09 at 21:00
    
I tried create a new 'location' called HOME and it works (meaning I can turn on my air port' I just don't understand why my 'Automatic' no long works. –  hap497 Dec 4 '09 at 3:26
    
See the edit in my answer. –  ridogi Dec 4 '09 at 5:42

I wonder what vintage MBP you are using?

I have the 2007 model (C/o Hardware Overview: MacBook Pro 17"; MacBookPro2,1; Intel Core 2 Duo; 2.33 GHz) and it's permanent refusal to auto logon to a known WiFi transmitter in spite of every attempt that I have made and every means & suggestion out there was a constant frustration. (Until I gave up fighting it, and now just accept that I'll have to manually connect each time I wake it up.) It still grates at times.

PassingBy

share|improve this answer
    
Duh. As so often happens, an input to a discussion re-triggers one's own brain, and the answer is found. When you go to Syst Prefs:Network, at the bottom of the (left) list is a tiny Tool icon. It offeres a Set sort order . . . option. Mine was set with Airport at the bottom of the list - no connectee Moving it to the top of the list fixes my problem, at least. Why the order in which the OS checks signal sources determines a connection is beyond me. (This in 10.5) Passing By –  PassingBy May 1 '10 at 1:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.