Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have so many errors in spelling ang grammer in my document. But when I click on ABC button, it says that apelling check is complete and returns no errors. I have full installation of Microsoft Office 2007 on vista. What is the problem?

share|improve this question
add comment

4 Answers 4

First, click the Microsoft Office Button, close it, and see if spell check begins to work. (Believe it or not, there's a slight bug with spell check and the Microsoft Office Button, you need to click it once for it to start working. Note that this only applies to new installations and it will only happen once.)

If that doesn't work then if no custom spell checker have been installed on the computer, exit Word, and then backup and delete the following registry key:

HKEY_CURRENT_USER\Software\Microsoft\SharedTools\ProofingTools\1.0\Override\en-US

This key will be rebuilt the next time you start Word.

Source

share|improve this answer
    
I dont have Override\en-US. But I have 2 entries inside 1.0: Custom dictionaries, Office. What should I do? –  pineapple Dec 4 '09 at 2:02
    
obviously, you DO have custom dictionaries installed, then DON'T delete this key. –  Molly7244 Dec 4 '09 at 2:26
    
Then what should I do to make my spelling check work? –  pineapple Dec 4 '09 at 2:27
    
do you have the MSO Installation disk? then run a repair installation. –  Molly7244 Dec 4 '09 at 2:28
add comment

It could be that the text language is not set to English.

In Word text has a language, just like it has a font and a color and a font size.

Select the entire document (Ctrl+A), then go to Review and choose Set Language from the "Proofing" toolbar. Set the language to English.

share|improve this answer
add comment

Try this:

Your office profile might be corrupted. Try this following soluton:

You need to make some changes in your Windows registry in order to fix the issue: 1. HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0 AND/OR 2. HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\ApplicationName(Word, Outlook, Exel, etc.)

Rename these keys by going to Start->Run, regedit, in registry editor navigate to the following keys and rename (right click) them to:

  1. HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0old

  2. HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlookold (example for Outlook spell check) OR HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Wordold (for Word spell check)

Reboot Windows and restart Office. MS Office will recreate the keys automatically.

Notes: Creating a new profile does the same thing. If your spell check works under a new profile, your current_user registry is corrupted, and this fix should work fine.

source

share|improve this answer
add comment
up vote 0 down vote accepted

My problem got solved after I installed full version. Earlier I installed by customization.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.