Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm helping a friend that can't connect to the internet through a hard wired connection or through wireless. It's a laptop, that usually connected fine through both.

The error is that the WiFi bars have a red X. If you click on it, it says "Not Connected. No Connections are available"

It's a windows 7 OS machine. Here are the steps I went through, would appreciate any other help:

  1. Make sure that hardware switches are turned ON on the side of the laptop (no switches found)
  2. Press the toggle on the keyboard to make sure it wasn't accidentally turned off (toggle didn't seem to toggle anything)
  3. Check device manager to see if any yellow exclamation points are present (no)
  4. After clicking the WiFi bars, then "Troubleshoot" (An unexpected error has occurred. The troubleshooting wizard can't continue)
  5. Go to network adapters (LAN and WiFi say "unplugged" and "not connected") Tried disabling WiFi adapter and reenabling. (Still doesn't work)
  6. In network adapters pressed "diagnose" ("An error occured while loading the troubleshooter")
  7. Go to cmd prompt as admin. Run "sfc /scannow" (after a certain % it stops and said "Windows Resource Protection could not perform the requested operation"
  8. Run "chkdsk /r", pressed y, then enter, then restart computer. Chkdsk is running. Walk away from computer for a few hours, come back to windows login screen.
  9. Try "sfc /scannow" again. No change.
  10. Uninstall both network adapters, press Action > Scan For Hardware Changes. Still doesn't work

I'm out of ideas. What else could this be.

EDIT (for bounty) I keep trying the same things as listed above, hoping something will just magically work, but it's proven unsuccessful. I've done everything I could possibly think of. I know the best solution would be "Just reinstall Windows", but right now that's not a possibility.

share|improve this question
    
Verify the wireless adapter supports the same modes as the access point. –  Ramhound Jul 22 at 2:59
    
Yes. It had connected to the access point before. This is not affecting only one access point, we have tried several. Also noted, is that a hard wired connection also doesn't work. –  EGHDK Jul 22 at 3:02
    
The drivers are installed for these devices. You don't indicate its all wireless access points. The LAN device not working was obvious on that front. The fact sfc /scannow is failing indicates the system integrity is beyond repair. –  Ramhound Jul 22 at 3:07
    
You mentioned in the question that SFC /scannow doesn't complete the scan. In that case you might want to try DISM /Online /Cleanup-Image /RestoreHealth. You'll need to start the command prompt as administrator of course. –  Vinayak Jul 29 at 18:40
    
Can you give me more background on that command? –  EGHDK Jul 30 at 0:42

7 Answers 7

I had a somewhat similar issue with a Win 7 machine a while back. It wasn't wireless just wired but it was having this same issue.

After doing close to the same steps that you have done, I did these things:

  1. Did Windows Update update the driver for your NIC?
  2. If so, then attempt a Driver Rollback.
  3. If not, verify that the NEWEST drivers for the NIC are installed.
  4. If not, install them.
  5. If this does not solve the issue then go back to the place that you found the drivers for your NIC, download ALL possible NIC drivers including ones for Vista and XP.
  6. Attempt installing each one to see if the issue is fixed.

In my case it was simply that Windows Update had installed the newest driver for the NIC and I needed to rollback to a Vista version of the driver. Unfortunately, I am not intelligent enough to explain the reason that the 'updated' version of the driver failed.

Also, SFC failing may be some foreshadowing of a larger problem or it could actually be the problem.

Good Luck!

share|improve this answer

This definitely sounds like a driver issue, but the fact both your wired and wireless connections don't work suggests the problem could be something else. The odds are somewhat against drivers for both of these devices becoming damaged at the same time.

Try looking at the Event Viewer in the System log for any error or warning messages related to networking, then Google any you aren't sure of.

A reasonably safe option to try is System Restore. You can revert the computer's settings to a point prior to the issue appearing (or several weeks back if you don't know when it stopped working). If this doesn't help you can always "undo" the System Restore. SR doesn't harm user-created documents, e-mails, etc.

share|improve this answer

Try resetting TCP/IP. To do this yourself, open a command prompt as administrator, and run the following:

netsh int ip reset

Also, open the adapter properties, make sure TCP/IPv4 is enabled, and that the properties are both set to "Obtain...address automatically".

share|improve this answer

You must take into consideration that the WiFi mini-card could have died. I will ask you to try two things:

  • Check the system BIOS to see If for some reason is disabled from here.
  • Connect a spare USB WiFi adaptor and see If this works.

It's unusual but I saw it happen some days ago. What is the model of the laptop ?

share|improve this answer

go into CMD (command prompt) and type this:

netsh wlan connect name="name of network trying to connect to"

use quotes if the network is more than 1 word.

Also try:

netsh interface set interface name="name of your wireless/wired adapter" admin=enabled

this will manually enable the adapter.

share|improve this answer

The issue is probably not a software one but a hardware one. Check for a button with icons such as these:

enter image description here

They will then show a prompt which will allow you to re-enable your wireless adapter. That is, in addition to you flipping on your hardware switch which may look like this:

enter image description here

share|improve this answer

Did you filp the switch on your wireless adapter? This happened to me once. If that works, I'll see about the wired connection afterwards. P.S. Is your connection settings set to auto? And are you connecting via a router?
Edit: Maybe it's a hardware thing, can you try to open up the computer and firmly press down on all cables?

share|improve this answer
    
He already done this –  Joey Jul 29 at 13:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.