Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I try to save something in my jEdit, it returns an error with the message:

The following I/O operation could not be completed (C:\Program Files\jEdit\Untitled-1: Cannot save: java.io.FileNotFoundException: C:\Program Files\jEdit#Untitled-1#save# (Access is denied))

What could be wrong?

share|improve this question

migrated from stackoverflow.com Dec 4 '09 at 10:30

This question came from our site for professional and enthusiast programmers.

6 Answers 6

up vote 1 down vote accepted

Judging by the error message, "Access is denied", I would say that it looks jEdit can't save because the user it's running as doesn't have write access in the target directory.

This could be a bug in jEdit however; looking at both file paths, it looks like it wants to modify the Untitled-1 file in the C:\Program Files\jEdit directory; however, it may actually be trying to edit a file called jEdit#Untitled-1#save# in C:\Program Files. It's believable that it would not have permissions to write to the latter.

One workaround would definitely be to eiter run jEdit as an admin user, or grant yourself write access to C:\Program Files. However, I would investigate the settings to see if you can change the directory jEdit is using for this rather than changing your system's security settings.

share|improve this answer

When trying to edit a python script in Inkscape "texttext.py" I get: java.io.FileNotFoundException permission denied.I have the latest version of Jedit 4.3.2 as of 12/12/2010 and I'am running on Windows 7 home basic. I have enabled all permissions, my disk is not full and I have the latest version of Java. Seams like a bug to me.

share|improve this answer

I dont know for certain, I have this error too, I am submitting a bug to the jedit tracker... but I believe it has to do with the fact that on vista and windows 7, there are write permissions that are special to the Program Files directory. You can change the default for the autosave, but you cannot change where the default unnamed file goes.

You can find jEdit here on Source Forge

share|improve this answer

There are some possible problems coming to my mind:

  • Your disk is full. Check: Create a new text file with notepad on C:\ with the content of your opened file
  • You use an illegal filename. Check: Use a simple new name
  • You don't have access to this folder. Check: Try saving to %appdata%. You must have access to this folder.
  • Propably a bug in jEdit. Download the latest version and retry.

Good luck!

share|improve this answer

I'm getting the same error. I actually don't want backups for untitled documents to be saved in Program Files. Is there a way to change the directory to something like C:\users\User1.jedit\backups without doing a saveas?

share|improve this answer

Work around (tested in Windows 7 x64 SP1): Change the jEdit shortcut (or make a new one) that has "Start in" directory C:\Backup\jEdit where "C:\Backup\jEdit" is your previously configured directory for jEdit backups. The auto-save #untitled-1# type files will be written there rather than the OS-protected C:\Program Files\jEdit.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.