Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to get Skype working on my Ubuntu machine (it works on the same machine if i run windows, with the same exact hardware). I can make calls just fine, but the microphone doesn't work with alsa. The skype download for oss worked a bit but the sound was very low, and it stopped working after a while (no idea why).

I tried the sound recorder application in ubuntu, but the mic didn't work there either.

I am quite lost, do anybody know what to do?

Edit: The mixer settings where correct, but now I just get "Problem with audio playback (this happens whether or not I use the oss or alsa version, whereas the oss version used to work). The sound does work from e.g. mplayer

share|improve this question

This is not strictly an answer to the question you asked, but why not try the new Skype 2.1 Beta for linux that came out a few days back? A whole slew of sound devices related errors seem to have been sorted out in this version by making Skype work exclusively through PulseAudio.

share|improve this answer
I used to have problems with previous version of skype, untill i started using this version. – Decio Lira Oct 1 '09 at 2:14

Have a look at the mixer settings, it's very likely that the channel is just muted at the moment.

Usually you can click the sound item in the task bar and select mixer / channels, and it'll give you a list of all available channels, and a menu item to add additional channels to the list if you're missing some in the basic list. You can then un-mute or adjust the volume of the channels you want.

I've heard good things about the gnome-alsamixer package.

share|improve this answer

For alsa: Check alsamixer to see if the relevant channels are muted or not.

share|improve this answer

If you are using the 64-bit version of Ubuntu, then Skype and Pulseaudio may be conflicting, because there is no 64-bit Skype, so what you're actually using is the 32-bit version. 32-bit Skype and 64-bit Pulseaudio seem to be unable to cooperate. I still haven't found a solution.

share|improve this answer

I got it working for me in alsa mixer. Open up a terminal and type:

alsamixer -c 0

Press Tab and change both input sources to front mic. Turn on front mic boost, increase capture and capture 1 as much as needed.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .