Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am just learning how to use the command line and was editing the bash prompt setting in .bash_profile.

I made an error in the prompt settings in .bash_profile and I lost the prompt and the ability to enter commands in terminal.

When I did this I noticed my MacBook pro got really hot and the fan came on. I eventually fixed the .bash_profile settings by opening it in TextEdit by New Command open -e .bash_profile in terminal.

I have my prompt and use of terminal back but my laptop is still running very hot. Does anyone know what is happening and how I can fix this?


Yes I am running OSX 10.9.4, The .bash_profile with the error was…

export PS1='$[\033[01;36m\]\u\[\033[01;35m\]@\h\[\033[01;33m\]:\[\033[01;31m\]\w\[\033[01;33$'
export CLICOLOR=1
export LSCOLORS=ExFxBxDxCxegedabagacad
alias ls='ls -GFh’

and after I corrected it is now:

export PS1='${debian_chroot:+($debian_chroot)}\[\033[01;36m\]\u\[\033[01;35m\]@\h\[\033[01;33m\]:\[\033[01;31m\]\w\[\033[01;33$'    
export CLICOLOR=1
export LSCOLORS=ExFxBxDxCxegedabagacad
alias ls='ls -GFh’

There are not applications running except firefox

share|improve this question
Could you show your .bash_profile? Did you check your activity monitor for programs running with high CPU usage? Which OS are we talking about (I assume OS X)? – Snicksie Jul 25 '14 at 9:27
I have added this information to the question, thankyou – Cu1ture Jul 25 '14 at 9:56
I guess you forgot to remove the $ at the beginning. export PS1='[\033[01;36m]\u[\033[01;35m]@\h[\033[01;33m]:[\033[01;31m]\w[\033[01;33$' doesn't give an error for me. The ${debian_chroot:+($debian_chroot)} is explained in the following post:… – Snicksie Jul 25 '14 at 10:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.